1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can you guys tell me about my new 6.9

Discussion in '6.9L IH & 7.3L IDI Diesels' started by Buffetkiller, Aug 6, 2019.

  1. Buffetkiller

    Buffetkiller Registered User

    Posts:
    33
    Likes Received:
    9
    Joined:
    Aug 6, 2019
    Location:
    Washington
    I have a couple questions. Why is my Excelerator pedal so hard to press? My leg gets tired just driving to work!
    And why does my fan stay on constant for about 5 to 7 minutes worth of driving when the motor is cold? Also when I’m on the freeway at speed it sounds like the fan will start slowly coming on and it will stay on for about 5 to 7 minutes before it slowly goes away
     
  2. IDIBRONCO

    IDIBRONCO IDIBRONCO

    Posts:
    4,024
    Likes Received:
    2,339
    Joined:
    Feb 5, 2010
    Location:
    edmond, ks
    The accelerator pedal, as it came from the factory, has two return springs with a third one as part of the throttle cable. Why this was done, I have no idea. I'm used to it so it's no big deal, but you could try removing one spring. The two on the injector pump are combined together. They are underneath the fast idle solenoid on the passenger's side of the pump. You'll need to remove them and then you can separate them. I'd put one back on just to make sure that the throttle will return. The one in the throttle cable may not be strong enough to push the throttle back to it's idle position.
     

Share This Page