So What Did You Do With Your PSD Today?

compressionignitionrules

Full Access Member
Joined
May 1, 2016
Posts
800
Reaction score
264
Location
Bluevale ON
with my powerstroke I dragged home an idi tonite for the wife and kids to drive , but it only has 3 cylinders and is pretty ragged...... ok its a kubota G1800 w/4wheel steer. needs lots of TLC but it is a lot more user friendly for the family than my JD 430, and weighs 5-600lbs less . I'll put soem pics up on sunday.
DSC03081.JPG DSC03082.JPG

actually rolled my lawn behind 1st cutting today was worried this little fella would get pushed around by roller , but I stayed off the steep spots . was going to finish it up today but my reaction finally hit me from my covid vaccine on thurs nite. WOW! wife had nothing. my daughter laughed at me and said I got the short straw.
 

bbjordan

Snow Monkey
Joined
Feb 24, 2011
Posts
1,388
Reaction score
348
Location
Calgary Alberta
Showed Fred, the PSD, some love, and put on some newer tires and painted Alcoa rims. The rims were a set of nasty corroded ones I had accumulated. After taking the crap tires off, I hit them with the wire wheel and painted them up. I wanted to have something closer to the colour of the truck. It is a little more gold looking than I expected, but it doesn't look too bad. The colour on the can said Champagne Mist.
I also painted the hubs with a black rust paint.

The phrase "Polishing a turd" comes to mind. :)

P_20210515_174214.jpg

P_20210515_174229.jpg

P_20210515_190055.jpg

P_20210515_190106.jpg
 
Last edited:

bbjordan

Snow Monkey
Joined
Feb 24, 2011
Posts
1,388
Reaction score
348
Location
Calgary Alberta
Swapped the turbo. I removed the Banks fast spool turbo, and put original turbo back on. This time with a Wicked Wheel 2 impeller. The truck was rolling coal too much for my liking. Maybe this will help.

I'd really like to have a wall to wall talk with the guy, or committee that designed this set-up.-cuss The 1999+ turbo and pedestal mounting design is so much better.
 
Last edited:

79jasper

Chickenhawk
Joined
Oct 13, 2012
Posts
17,366
Reaction score
1,911
Location
Collinsville, Oklahoma
Do you think the quick spool was too much restriction?
I had the 1.0 or .9 or mine with the diy d66, worked well.

Sent from my SM-G988U using Tapatalk
 

bbjordan

Snow Monkey
Joined
Feb 24, 2011
Posts
1,388
Reaction score
348
Location
Calgary Alberta
I wasn't sufficiently impressed with the fast spool turbo, so I switched back to the original...well, with the WW2. Today I checked the Exhaust Back Pressure Sensor tube for restriction...yup plugged. I cleaned it out, so now I'll see if there's a difference. I'm doing things backwards, I know :idiot:, but that's how I roll. lol
 

Bradd Barmettler

Tow&Slow
Joined
Dec 22, 2020
Posts
322
Reaction score
170
Location
Newport Beach, CA
Showed Fred, the PSD, some love, and put on some newer tires and painted Alcoa rims. The rims were a set of nasty corroded ones I had accumulated. After taking the crap tires off, I hit them with the wire wheel and painted them up. I wanted to have something closer to the colour of the truck. It is a little more gold looking than I expected, but it doesn't look too bad. The colour on the can said Champagne Mist.
I also painted the hubs with a black rust paint.

The phrase "Polishing a turd" comes to mind. :)


So fancy, I like it!
 
Top