1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Charging Issue

Discussion in '6.9L IH & 7.3L IDI Diesels' started by catbird7, Oct 21, 2019.

  1. saburai

    saburai Supporting Member Supporting Member

    Posts:
    1,817
    Likes Received:
    729
    Joined:
    Mar 15, 2016
    Location:
    Bokeelia Florida/Catskill mountains NY
    20/20 hindsight...
     
    catbird7 likes this.
  2. catbird7

    catbird7 Full Access Member

    Posts:
    1,091
    Likes Received:
    806
    Joined:
    Feb 15, 2011
    Location:
    PA
    Going to stop on the way home this evening and pick up four new belts to replace everything on the engine and a 24" pre-made wire to use as a ground from alt to neg post on battery. That should just about put an "Amen" to it!
     
    Selahdoor likes this.
  3. saburai

    saburai Supporting Member Supporting Member

    Posts:
    1,817
    Likes Received:
    729
    Joined:
    Mar 15, 2016
    Location:
    Bokeelia Florida/Catskill mountains NY
    Not that I've ever experienced it myself :rolleyes:
     
    Selahdoor likes this.
  4. Matt Dierks

    Matt Dierks Registered User

    Posts:
    6
    Likes Received:
    1
    Joined:
    Nov 14, 2019
    Location:
    Fort Calhoun, Nebraska
    I had erratic volt meter issues before and now after installing my new CARQUEST Alternator that is the internal volt regulated one just as my previous one was. I can hit bumps and rattle the piss out of the truck and no issue. Going down the smooth highway it will give me the battery warning light and then go back to charging. Like stated prior, it did this exact thing before the new alternator and is still doing it. I have checked for loose connections and all seems fine. I am going to do a ground connections check and see if there are any loose frame, motor grounds? Any help is appreciated, thanks!
     

Share This Page