1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"93 7.3 N/A need advice no turn over

Discussion in '6.9L IH & 7.3L IDI Diesels' started by Jason1377, Mar 1, 2019.

  1. Jake60

    Jake60 Full Access Member

    Posts:
    54
    Likes Received:
    67
    Joined:
    Feb 3, 2019
    Location:
    New Jersey
    At least some sandpaper. With a new starter and a good battery it's a bad ground 99% of the time, either battery to frame or frame to block.
     
  2. Thewespaul

    Thewespaul Supporting Vendor Supporting Member

    Posts:
    6,383
    Likes Received:
    4,397
    Joined:
    Jul 27, 2015
    Location:
    Bulverde, Texas
    You said you replaced the cables, I’m willing to bet either the smaller wire coming from the ground on the core support to the driver side battery ground or the wire going to the frame to engine. Having both or one of these missing will not allow the ignition switch to function. Just ran into this with a truck today.
     
  3. franklin2

    franklin2 Full Access Member

    Posts:
    3,646
    Likes Received:
    310
    Joined:
    Feb 24, 2009
    Location:
    Va
    I thought he said it would turn over, but slowly?
     
  4. Jason1377

    Jason1377 Supporting Member Supporting Member

    Posts:
    636
    Likes Received:
    213
    Joined:
    Dec 12, 2017
    Location:
    Arkansas

    That's been my goal replace that as well positive cable done passenger side negative cable a pain in the ass to do drive side this weekend if there's no rain fresh batteries, new cuss words n life experience
     

Share This Page