1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

'87 6.9 idi no fuel, Injection pump?

Discussion in '911 Diesel Down!' started by Ford420ci6point9, Jan 6, 2019.

  1. Ford420ci6point9

    Ford420ci6point9 Full Access Member

    Posts:
    70
    Likes Received:
    16
    Joined:
    May 22, 2018
    Location:
    Stafford Spring CT
    I cant start my truck, It cranked fine this morning and started sputtering to life like normal, then it stopped sputtering and it hasn't gotten fuel since, I verified the fuel was getting to the filter from the lift pump and it is fine. I cracked a injection line at the injector and nothing, cracked one from the IP, nothing, took off front cover of the oil fill spout verified it does turn, then I cleaned the contacts on the electric shut off switch, nothing. I'm out of ideas. IP's don't just die do they? It drove and started fine yesterday. I need that thing to haul 6 tons of granite today! GRR!!! HELP!!!
     
  2. Thewespaul

    Thewespaul Supporting Vendor Supporting Member

    Posts:
    5,758
    Likes Received:
    3,694
    Joined:
    Jul 27, 2015
    Location:
    Bulverde, Texas
    Sounds electrical, with the key on do you hear a click when you connect the front prong on the ip?
     
  3. Ford420ci6point9

    Ford420ci6point9 Full Access Member

    Posts:
    70
    Likes Received:
    16
    Joined:
    May 22, 2018
    Location:
    Stafford Spring CT
    ill try that
     
  4. Ford420ci6point9

    Ford420ci6point9 Full Access Member

    Posts:
    70
    Likes Received:
    16
    Joined:
    May 22, 2018
    Location:
    Stafford Spring CT
    Yep I hear a click, although I did notice a second wire to a sort of solenoid to the left of the ip, and that wire has no power, but the fuel shutoff switch does have 12v to it.
     
  5. Thewespaul

    Thewespaul Supporting Vendor Supporting Member

    Posts:
    5,758
    Likes Received:
    3,694
    Joined:
    Jul 27, 2015
    Location:
    Bulverde, Texas
    Has your high idle always worked? If you have a click you should have fuel. Do you have a tach to read what rpm you are cranking at?
     
  6. Ford420ci6point9

    Ford420ci6point9 Full Access Member

    Posts:
    70
    Likes Received:
    16
    Joined:
    May 22, 2018
    Location:
    Stafford Spring CT
    Oh that's high idle, ok, no it has never worked. I use a stick to warm her up. I do have a tach and I crank at about 400. I just tried starting with to cars jumped to it and it spun like crazy, like above idle speed, probably to 600 rpm. Nothing, not a sputter or a cough.
     
  7. Oledirtypearl86

    Oledirtypearl86 Full Access Member

    Age:
    33
    Posts:
    456
    Likes Received:
    216
    Joined:
    Sep 17, 2018
    Location:
    Whitehall MT
    I don't want to say it but a small dose of ether might be the kick in the pants the old girl needs
     
  8. Ford420ci6point9

    Ford420ci6point9 Full Access Member

    Posts:
    70
    Likes Received:
    16
    Joined:
    May 22, 2018
    Location:
    Stafford Spring CT
    Already tried that, the ether just made her knock-aknock-aknock-aknock there is zero fuel going anywhere past the injection pump inlet, I just don't know, they don't just suddenly break do they?
     
  9. Thewespaul

    Thewespaul Supporting Vendor Supporting Member

    Posts:
    5,758
    Likes Received:
    3,694
    Joined:
    Jul 27, 2015
    Location:
    Bulverde, Texas
    It’s either two things, your head seized and the driveshaft snapped (it’s designed to do this) from fuel contamination or your inlet screen is completely clogged on the inlet of the injection pump. Both are very rare scenarios, but if the screen is plugged you won’t have any fuel returning from the pump, if the driveshaft snapped you will.
     
  10. Oledirtypearl86

    Oledirtypearl86 Full Access Member

    Age:
    33
    Posts:
    456
    Likes Received:
    216
    Joined:
    Sep 17, 2018
    Location:
    Whitehall MT
    Oooooo how cold is it where your at
     
  11. Ford420ci6point9

    Ford420ci6point9 Full Access Member

    Posts:
    70
    Likes Received:
    16
    Joined:
    May 22, 2018
    Location:
    Stafford Spring CT
    I have zero fuel at all from the pump outlets. Thanks for the suggestion
     
  12. Ford420ci6point9

    Ford420ci6point9 Full Access Member

    Posts:
    70
    Likes Received:
    16
    Joined:
    May 22, 2018
    Location:
    Stafford Spring CT
    Oh maybe 15-20 ish rn
     
  13. Oledirtypearl86

    Oledirtypearl86 Full Access Member

    Age:
    33
    Posts:
    456
    Likes Received:
    216
    Joined:
    Sep 17, 2018
    Location:
    Whitehall MT
    That's not bad I was thinking maby had some guel gelling
     

Share This Page