1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

02 7.3 runs and idles but has miss under load

Discussion in '7.3L Powerstroke Diesels' started by Oledirtypearl86, Jul 31, 2020.

  1. Oledirtypearl86

    Oledirtypearl86 Full Access Member

    Age:
    34
    Posts:
    1,363
    Likes Received:
    701
    Joined:
    Sep 17, 2018
    Location:
    Whitehall MT
    So been dicking around with the truck this morning and now I get random number 7 fail on a contribution test its not everytime and we put a new in idm in it
     
  2. Oledirtypearl86

    Oledirtypearl86 Full Access Member

    Age:
    34
    Posts:
    1,363
    Likes Received:
    701
    Joined:
    Sep 17, 2018
    Location:
    Whitehall MT
    So everything is in spec its got to be a wiring its a quick cut in fuel it seems just under load its very quick cut out like less than a second any ideas
     
  3. greenskeeper

    greenskeeper Full Access Member

    Posts:
    705
    Likes Received:
    88
    Joined:
    Mar 16, 2013
    Location:
    hatfield pa
    CPS sensor or pigtail can act like that prior to total failure
     
  4. Oledirtypearl86

    Oledirtypearl86 Full Access Member

    Age:
    34
    Posts:
    1,363
    Likes Received:
    701
    Joined:
    Sep 17, 2018
    Location:
    Whitehall MT
    Ok I guess I'll get the old ohm meter out
     
  5. lotzagoodstuff

    lotzagoodstuff Supporting Member Supporting Member

    Posts:
    2,315
    Likes Received:
    265
    Joined:
    May 19, 2007
    Location:
    Maple Valley, WA
    Just change the CPS, put the old one in your glovebox as a spare. If it fixes your problem, the installation time on the CPS is pretty easy and you'll feel like a million bucks. If it doesn't fix it, you'll be $30 poorer but have a spare for when the new one craps out down the road.
     
    Kevin 007 likes this.

Share This Page