1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

02 7.3 runs and idles but has miss under load

Discussion in '7.3L Powerstroke Diesels' started by Oledirtypearl86, Jul 31, 2020.

  1. Oledirtypearl86

    Oledirtypearl86 Full Access Member

    Age:
    34
    Posts:
    1,351
    Likes Received:
    690
    Joined:
    Sep 17, 2018
    Location:
    Whitehall MT
    So buddy of mine has a 02 with 235k miles we just did injectors and cups on it anf it still has a miss under load in the past few weeks before he asked me for help he put anew icp sensor ipr and crank position sensor it isnt throwing any codes and the tuner is set to stock any ideas we could really need some help
     
  2. greenskeeper

    greenskeeper Full Access Member

    Posts:
    679
    Likes Received:
    85
    Joined:
    Mar 16, 2013
    Location:
    hatfield pa
    Was the miss under load present before the injector and cup replacement?
     
    Oledirtypearl86 likes this.
  3. Oledirtypearl86

    Oledirtypearl86 Full Access Member

    Age:
    34
    Posts:
    1,351
    Likes Received:
    690
    Joined:
    Sep 17, 2018
    Location:
    Whitehall MT
    Yes it was
     
  4. Kevin 007

    Kevin 007 Full-floater

    Posts:
    1,756
    Likes Received:
    85
    Joined:
    Mar 14, 2011
    Location:
    Nelson BC Canada
    Could the miss possibly be mistaken for an exhaust leak that's only audible under load?
     
    Oledirtypearl86 likes this.
  5. Oledirtypearl86

    Oledirtypearl86 Full Access Member

    Age:
    34
    Posts:
    1,351
    Likes Received:
    690
    Joined:
    Sep 17, 2018
    Location:
    Whitehall MT
    No its a noticable mis and puff of white smoke there is nothing subtle about it
     
  6. lotzagoodstuff

    lotzagoodstuff Supporting Member Supporting Member

    Posts:
    2,298
    Likes Received:
    254
    Joined:
    May 19, 2007
    Location:
    Maple Valley, WA
    If you have a known good IDM, I'd swap it out and see if it does the same thing.
     
    Oledirtypearl86 likes this.
  7. Kevin 007

    Kevin 007 Full-floater

    Posts:
    1,756
    Likes Received:
    85
    Joined:
    Mar 14, 2011
    Location:
    Nelson BC Canada
    How about UVCH's? Were they replaced when you had the valve covers off?
     
    lotzagoodstuff likes this.
  8. greenskeeper

    greenskeeper Full Access Member

    Posts:
    679
    Likes Received:
    85
    Joined:
    Mar 16, 2013
    Location:
    hatfield pa
    What is your fuel pressure under load ?

    Check the IDM for water intrusion
     
    Oledirtypearl86 likes this.
  9. Kevin 007

    Kevin 007 Full-floater

    Posts:
    1,756
    Likes Received:
    85
    Joined:
    Mar 14, 2011
    Location:
    Nelson BC Canada
    Have you had the chance to run a cyl contribution test?
     
  10. Oledirtypearl86

    Oledirtypearl86 Full Access Member

    Age:
    34
    Posts:
    1,351
    Likes Received:
    690
    Joined:
    Sep 17, 2018
    Location:
    Whitehall MT
    That's where my mind was going but I don't have one and yes IV buzzed and done a contribution test both are good
     
  11. 264WSM

    264WSM Full Access Member

    Posts:
    55
    Likes Received:
    10
    Joined:
    Nov 25, 2017
    Location:
    Wyotana
    Throttle position sensor?
     
  12. Oledirtypearl86

    Oledirtypearl86 Full Access Member

    Age:
    34
    Posts:
    1,351
    Likes Received:
    690
    Joined:
    Sep 17, 2018
    Location:
    Whitehall MT
    Igotmy computer back today so I'm going to give it a proper rundown again
     
  13. Oledirtypearl86

    Oledirtypearl86 Full Access Member

    Age:
    34
    Posts:
    1,351
    Likes Received:
    690
    Joined:
    Sep 17, 2018
    Location:
    Whitehall MT
    Pulling a p0605
     
  14. 79jasper

    79jasper Chickenhawk

    Age:
    27
    Posts:
    17,101
    Likes Received:
    1,751
    Joined:
    Oct 13, 2012
    Location:
    Collinsville, Oklahoma
    Common with a chip installed. Also can come up after disconnected batteries.

    Sent from my SM-N960U using Tapatalk
     
  15. greenskeeper

    greenskeeper Full Access Member

    Posts:
    679
    Likes Received:
    85
    Joined:
    Mar 16, 2013
    Location:
    hatfield pa
    That code is almost always there, especially with a chip. Nothing is wrong with having that code.
     
    Oledirtypearl86 likes this.

Share This Page