Transmission Hell

Max Mini

Registered User
Joined
Jun 27, 2019
Posts
72
Reaction score
16
Location
02451
So... you may have seen my previous thread, where the mechanic who installed my transmission tried to convince me I had somehow gotten an E4OD with a manual shift valve body from Monster Transmission. That is of course not true. The transmission at the time I posted that thread would only shift manually and didn't have first or overdrive. Some progress has been made, but things are still not right. It would be easy to lay the issue at the feet of Monster Transmission, but I don't think that's where it belongs. Bear in mind I'm not a mechanic and everything I know about transmissions I've basically learned from this mess, but it seems to me there is something underlying that was going on before this transmission went in. I say this because I've put 3 transmissions in this little bus in 5 years, though the first one probably just crapped out. It's a '91 7.3 idi short school bus, and I live in it and travel full time. I'm giving probably way too much info here, but it's in the hope that someone will see a pattern or something.

1) Transmission #1 (the one the bus came with) died in the middle of a cross country drive from California to Massachusetts. Got a rebuilt transmission installed in Iowa, in July 2018.
2) Mid 2019, 6000 miles later, I start having issues, over-revving when shifting. I take it to a shop and they tell me codes pointed to FIPL, so they replace it.
3) I didn't drive a whole lot in 2020, taking care of my Mom in MA and the whole lockdown thing. More issues in early 2021, though, intermittent shifting issues. At that point I was having a really hard time finding mechanics interested in working on it: too small for big diesel shops, too big for small truck shops, and too old for everybody else. Though it wasn't quite right, things were not drastically bad, I was able to get around and even take a couple of longer trips without significant issues until -
4) April 2022, on the west coast end of another cross country drive, similar issues come up. Again it's almost impossible to find a mechanic, but finally one turns up in Las Vegas. Again, codes point to FIPL. Again, they replace it. I questioned whether that made sense since the one in there was only 2 years old and the bus had not been driven that much in the intervening time, but the shop was adamant that code means it has to be replaced.
5) June of 2022, alternator went out. it was very clearly the alternator that was the issue, but it was again throwing the FIPL code. Mechanic who did the alternator said codes are unreliable and probably it was just putting out that one because the TPS wasn't getting enough power since the alternator was on the way out.
6) October of 2022, transmission #2 dies. Despite having looked normal not too long before, fluid at that point was almost as black as oil. Tons of metal in the pan.
7) My regular Massachusetts mechanic found a used transmission from a similar bus, put that in. Transmission #3. Right from the start, it wasn't right. Intermittently very sluggish going from stop into first, and over revving when shifting. But at other times, it worked fine. I brought it back to my mechanic, he kept it for a while, drove it, told me he didn't see anything wrong. Looking at the odometer afterwards, I saw he had only driven it 16 miles. I know my bus pretty well at this point, and I knew something was wrong, but I'm a woman who's pretty new to even talking about diesel engines, and he's a guy who's been a diesel mechanic for 40 years. He's insisting it's all fine, so eventually, I just said ok and left.
8) A month later, as I'm embarking on another trip across the country, the OD off light starts flashing. I pull over and call the mechanic, who tells me he's 99.9% confident in this transmission and those lights are notorious for failing. It's probably just the light. I wanted to believe him, I really did, because I wasn't looking forward to another Massachusetts winter, so I drove onward. The light flashed for at least 1500 miles, but things weren't TOO bad. By the time I got to Texas, though, the overdrive was intermittently going out again.
9) In January, in Arizona, I suddenly had a big struggle getting into first, and as I attempted to drive it on a long grade, I realized overdrive wasn't happening at all. When I pulled off at the exit, all the transmission fluid spewed out of it, and the bus came to a dead stop.
10) A mobile mechanic got it moving enough to get to a safe spot in the desert where I could just hang for a while. He looks for about a week for another transmission to put in, then when he can't find one he says he can rebuild what I have. This turned into a two month ordeal. This guy was, in my opinion, in way over his head, with more confidence than skill. I don't think he really knew how to rebuild my transmission. But by the time I figured that out, he had taken it, I was stuck immobile in the desert, and I had no choice but to wait for him to put it back in. I'm in an area with not a lot of services, and the local shops were booked weeks and weeks out, so it's not like there were a lot of alternatives.
11) 6 weeks later he puts the rebuilt transmission back in and tells me it's done, but he barely finger tightened half the bolts and left the other half out entirely, which I didn't find out until after the test drive. On that drive, he's supposedly following right behind me, and it's clear the transmission won't shift out of first at all. Turns out, he's NOT right behind me, though. He's gone. The guy ghosted me completely in the middle of the test drive, never to be seen again. Over the course of those six weeks he had managed to convince me to pay him over a thousand dollars supposedly for various parts, and then he took off, leaving me back at square one. Transmission #3 is toast. I'm not going to go for a rebuild now that it's been disassembled and put back together by someone who doesn't seem to know what he's doing.
12) I find another mobile mechanic who comes very highly recommended, is supposedly the only good one in town, but he's a winter resident and planning to leave at the end of March (I was only planning to be there a week myself but at that point it had been two months). He says if I get a transmission in time he'll put it in. The only place I can get one quickly enough is Monster Transmission. I purchase Transmission #4. They're in Florida, it's hard to get large freight to Quartzsite, and there are issues with their shipper, but they jump through hoops on conference calls with me and the shipper and finally get the transmission there in two weeks - with the wrong torque converter. Mine has a four stud bolt pattern, the one they send is 6 studs. A few calls to Ford make it clear the one they sent can't be installed in my vehicle, we need the 4 bolt. So Monster ships out a new one overnight (which takes two days, this being Quartzsite).
13) Once the torque converter arrives, the transmission finally gets installed! Yay! But... it can only be manually shifted, and mechanic attempts to convince me it's a manual shift valve body (he is leaving town in a few days and wants this over with). There is no first gear, I have to shift manually from second to third, and there is no overdrive. At my insistence, he looks at it again a few days later, finds the transmission is getting no power. There's a broken fusable link. He fixes it, gets power - and it still won't shift except manually. He shrugs his shoulders and leaves town.
14) I tell Monster what's going on, they believe it is the solenoid. They ship off a solenoid pack. Meanwhile I have convinced a really great, highly experienced mechanic a few towns over who is way overbooked to at least look at it.
15) That mechanic gets 9 codes, of which he says 7 pertain to the solenoid, with the remaining two pointing to the FIPL. He ends up installing the solenoid pack sent by Monster, and lo and behold, IT SHIFTS! Everything is working - except, he advises, you need to get that FIPL adjusted or you're going to have problems. He can't do it, doesn't have the time, and doesn't have a STAR reader. The only issue I'm experiencing is that it occasionally doesn't want to shift, but as soon as I back off the pedal, it kicks down. So ok, I'm thinking, all is well, it just needs this tiny tweak. Once the TPS/FIPL Is adjusted I'll be golden. It works fine for two days (except for the little issue I mentioned) as I wait for my appointment with a different mechanic to get the TPS adjusted. It feels like I am headed for the finish line - after almost three months of this. But nope.
16) I find a mechanic who says he can adjust it, but he says no one uses STAR readers anymore. He will follow the protocol Ford currently puts out for this issue, and he adjusts it to the recommended voltage. He even prints out the specs from Ford for me, confirming I'm now in range. But as soon as I go on the highway.... the OD OFF light starts flashing again, the overdrive is GONE. It's not shifting into third properly either, though it is eventually shifting. It was ALMOST PERFECT after the new solenoid pack went in and before the TPS adjustment... now it's a mess again.

And that's where I am now. A technician from Monster is calling me in the morning, and then doing a conference call with me and the current mechanic, the one who adjusted the FIPL. the guy who put in the solenoid says he checked the wiring and there is not a wiring issue, but at this point, I don't know. The reason I am reluctant to say the transmission itself is the issue is that the behavior was so similar with the previous transmission, and even the one before that. Any suggestions are welcomed with open arms. I need to figure this out!
 
Last edited:

asmith

Full Access Member
Joined
Jan 28, 2012
Posts
676
Reaction score
221
Location
Atascadero, Ca
man I am not any help here with what to do on your transmission, but i do want to say I am sorry you have gone through all of this. Those shady mechanics that ripped you off are terrible people and hopefully will get whats coming to them and soon. I will say, yes, you want the FIPL adjusted properly otherwise your transmission wont shift right. other than that @trackspeeder seems to be the resident transmission expert around here so hopefully he chimes in soon with some ideas and solutions for you.
where are you now? still in Quartzsite?
 

BeastMaster

Full Access Member
Joined
Feb 7, 2017
Posts
345
Reaction score
296
Location
Orange, California
I believe the E4OD requires five inputs to determine how to set the transmission solenoids.

* FIPL - Cues the controller on how fast you want to go .

* Tach Sensor - whether you have a tach display or not. - Cues the controller on how fast the engine is turning.

* Speedometer / VSS - Vehicle Speed Sensor - Cues the controller on how fast the tires are spinning. This signal comes from the speedometer.

* Brake - Cues the controller that it should no longer try to supply torque from the engine through the transmission.

* PRNDL - The position of the gear selector lever.

If any of these are supplying bad information to the controller, the controller will likewise give the transmission instruction that may use the engine and truck kinetics to destroy the transmission.

You need an experienced mechanic to fix this. It's not just a matter of swapping a failed transmission.

Something else is doing you in.

Without personally setting up your system with digital storage oscilloscopes, I would be only guessing in the dark.

It took several months of tapping controller input and output lines for me to chase an intermittent failure back to an intermittent PSOM, which, ironically, was getting perfectly good input from the speed sensor, rock steady display on the dial, but once in a while, not tell the transmission controller my accurate speed.

Confusion resulted which would have destroyed my transmission has I ignored it. Well, it would work, most of the time.

Once the microcontroller made the scene, things changed a lot as the new breed of service people were trained to believe code readers.

And in my case, the code pointed to a sensor, which was replaced twice, to no avail. This took old-school troubleshooting tech to isolate. Oscilloscopes and knowing exactly what it's supposed to do, and a way to see what the controller did, and why.

It took two of us to fix mine.

The transmission guy knew my E4OD in and out, but wasn't at home with microcontroller design. I know microcontrollers. I used to design them, but only had a layman's knowledge of transmission operations. I was lucky enough to find a transmission shop that would work with me.

Don't be surprised if you get turned down a lot. I did. Very few mechanics are comfortable with electronics. But there are a few, usually old guys who grew up at a time we used to build controllers as hobbies. We no longer build in the USA,. We outsource. Not too many of us old 60's engineers left. All this copyright law and intellectual property protection stuff is leaving us quite ignorant on how our stuff works.
 
Last edited:

hacked89

Full Access Member
Joined
May 30, 2018
Posts
1,811
Reaction score
2,435
Location
Bucks County PA
So... you may have seen my previous thread, where the mechanic who installed my transmission tried to convince me I had somehow gotten an E4OD with a manual shift valve body from Monster Transmission. That is of course not true. The transmission at the time I posted that thread would only shift manually and didn't have first or overdrive. Some progress has been made, but things are still not right. It would be easy to lay the issue at the feet of Monster Transmission, but I don't think that's where it belongs. Bear in mind I'm not a mechanic and everything I know about transmissions I've basically learned from this mess, but it seems to me there is something underlying that was going on before this transmission went in. I say this because I've put 3 transmissions in this little bus in 5 years, though the first one probably just crapped out. It's a '91 7.3 idi short school bus, and I live in it and travel full time. I'm giving probably way too much info here, but it's in the hope that someone will see a pattern or something.

1) Transmission #1 (the one the bus came with) died in the middle of a cross country drive from California to Massachusetts. Got a rebuilt transmission installed in Iowa, in July 2018.
2) Mid 2019, 6000 miles later, I start having issues, over-revving when shifting. I take it to a shop and they tell me codes pointed to FIPL, so they replace it.
3) I didn't drive a whole lot in 2020, taking care of my Mom in MA and the whole lockdown thing. More issues in early 2021, though, intermittent shifting issues. At that point I was having a really hard time finding mechanics interested in working on it: too small for big diesel shops, too big for small truck shops, and too old for everybody else. Though it wasn't quite right, things were not drastically bad, I was able to get around and even take a couple of longer trips without significant issues until -
4) April 2022, on the west coast end of another cross country drive, similar issues come up. Again it's almost impossible to find a mechanic, but finally one turns up in Las Vegas. Again, codes point to FIPL. Again, they replace it. I questioned whether that made sense since the one in there was only 2 years old and the bus had not been driven that much in the intervening time, but the shop was adamant that code means it has to be replaced.
5) June of 2022, alternator went out. it was very clearly the alternator that was the issue, but it was again throwing the FIPL code. Mechanic who did the alternator said codes are unreliable and probably it was just putting out that one because the TPS wasn't getting enough power since the alternator was on the way out.
6) October of 2022, transmission #2 dies. Despite having looked normal not too long before, fluid at that point was almost as black as oil. Tons of metal in the pan.
7) My regular Massachusetts mechanic found a used transmission from a similar bus, put that in. Transmission #3. Right from the start, it wasn't right. Intermittently very sluggish going from stop into first, and over revving when shifting. But at other times, it worked fine. I brought it back to my mechanic, he kept it for a while, drove it, told me he didn't see anything wrong. Looking at the odometer afterwards, I saw he had only driven it 16 miles. I know my bus pretty well at this point, and I knew something was wrong, but I'm a woman who's pretty new to even talking about diesel engines, and he's a guy who's been a diesel mechanic for 40 years. He's insisting it's all fine, so eventually, I just said ok and left.
8) A month later, as I'm embarking on another trip across the country, the OD off light starts flashing. I pull over and call the mechanic, who tells me he's 99.9% confident in this transmission and those lights are notorious for failing. It's probably just the light. I wanted to believe him, I really did, because I wasn't looking forward to another Massachusetts winter, so I drove onward. The light flashed for at least 1500 miles, but things weren't TOO bad. By the time I got to Texas, though, the overdrive was intermittently going out again.
9) In January, in Arizona, I suddenly had a big struggle getting into first, and as I attempted to drive it on a long grade, I realized overdrive wasn't happening at all. When I pulled off at the exit, all the transmission fluid spewed out of it, and the bus came to a dead stop.
10) A mobile mechanic got it moving enough to get to a safe spot in the desert where I could just hang for a while. He looks for about a week for another transmission to put in, then when he can't find one he says he can rebuild what I have. This turned into a two month ordeal. This guy was, in my opinion, in way over his head, with more confidence than skill. I don't think he really knew how to rebuild my transmission. But by the time I figured that out, he had taken it, I was stuck immobile in the desert, and I had no choice but to wait for him to put it back in. I'm in an area with not a lot of services, and the local shops were booked weeks and weeks out, so it's not like there were a lot of alternatives.
11) 6 weeks later he puts the rebuilt transmission back in and tells me it's done, but he barely finger tightened half the bolts and left the other half out entirely, which I didn't find out until after the test drive. On that drive, he's supposedly following right behind me, and it's clear the transmission won't shift out of first at all. Turns out, he's NOT right behind me, though. He's gone. The guy ghosted me completely in the middle of the test drive, never to be seen again. Over the course of those six weeks he had managed to convince me to pay him over a thousand dollars supposedly for various parts, and then he took off, leaving me back at square one. Transmission #3 is toast. I'm not going to go for a rebuild now that it's been disassembled and put back together by someone who doesn't seem to know what he's doing.
12) I find another mobile mechanic who comes very highly recommended, is supposedly the only good one in town, but he's a winter resident and planning to leave at the end of March (I was only planning to be there a week myself but at that point it had been two months). He says if I get a transmission in time he'll put it in. The only place I can get one quickly enough is Monster Transmission. I purchase Transmission #4. They're in Florida, it's hard to get large freight to Quartzsite, and there are issues with their shipper, but they jump through hoops on conference calls with me and the shipper and finally get the transmission there in two weeks - with the wrong torque converter. Mine has a four stud bolt pattern, the one they send is 6 studs. A few calls to Ford make it clear the one they sent can't be installed in my vehicle, we need the 4 bolt. So Monster ships out a new one overnight (which takes two days, this being Quartzsite).
13) Once the torque converter arrives, the transmission finally gets installed! Yay! But... it can only be manually shifted, and mechanic attempts to convince me it's a manual shift valve body (he is leaving town in a few days and wants this over with). There is no first gear, I have to shift manually from second to third, and there is no overdrive. At my insistence, he looks at it again a few days later, finds the transmission is getting no power. There's a broken fusable link. He fixes it, gets power - and it still won't shift except manually. He shrugs his shoulders and leaves town.
14) I tell Monster what's going on, they believe it is the solenoid. They ship off a solenoid pack. Meanwhile I have convinced a really great, highly experienced mechanic a few towns over who is way overbooked to at least look at it.
15) That mechanic gets 9 codes, of which he says 7 pertain to the solenoid, with the remaining two pointing to the FIPL. He ends up installing the solenoid pack sent by Monster, and lo and behold, IT SHIFTS! Everything is working - except, he advises, you need to get that FIPL adjusted or you're going to have problems. He can't do it, doesn't have the time, and doesn't have a STAR reader. The only issue I'm experiencing is that it occasionally doesn't want to shift, but as soon as I back off the pedal, it kicks down. So ok, I'm thinking, all is well, it just needs this tiny tweak. Once the TPS/FIPL Is adjusted I'll be golden. It works fine for two days (except for the little issue I mentioned) as I wait for my appointment with a different mechanic to get the TPS adjusted. It feels like I am headed for the finish line - after almost three months of this. But nope.
16) I find a mechanic who says he can adjust it, but he says no one uses STAR readers anymore. He will follow the protocol Ford currently puts out for this issue, and he adjusts it to the recommended voltage. He even prints out the specs from Ford for me, confirming I'm now in range. But as soon as I go on the highway.... the OD OFF light starts flashing again, the overdrive is GONE. It's not shifting into third properly either, though it is eventually shifting. It was ALMOST PERFECT after the new solenoid pack went in and before the TPS adjustment... now it's a mess again.

And that's where I am now. A technician from Monster is calling me in the morning, and then doing a conference call with me and the current mechanic, the one who adjusted the FIPL. the guy who put in the solenoid says he checked the wiring and there is not a wiring issue, but at this point, I don't know. The reason I am reluctant to say the transmission itself is the issue is that the behavior was so similar with the previous transmission, and even the one before that. Any suggestions are welcomed with open arms. I need to figure this out!
whenever you see the O/D light blinking know that you are burning up the trans. It’s time to stop, not keep driving. The fake mechanics aside, the parts of your story where people told you to keep driving with the O/D flashing led to the quick death of those.

It’s going to flash because of either a bad tc or “sensor/electrical input”. You swapped tc and didn’t fix it.

Can you post the exact codes that came back on the latest scan?
 

trackspeeder

Stone crusher.
Joined
Dec 21, 2003
Posts
4,094
Reaction score
238
Location
North Branford. CT
You will need to scan it for codes. It will have them.
When you see the OD Off light flashing, the tranny is in high pressure (limp mode).
This is a default setting to get you off the road.

At this point you know the tranny has power because it worked.
Check the TPS for dead spots. It could be set perfectly, but with a dead spot the TCM will go crazy.

Check the VSS . 91 model it will be on the tail shaft with the speedometer cable attached to it. If its original change it.

Again, pull the codes. Because it worked for a short time. So it shouldn't be an internal problem.
 

Nero

HD Diesel nut
Joined
Jan 3, 2022
Posts
2,474
Reaction score
2,520
Location
OR
My in laws truck I had the E4od rebuilt. It had a failed vss signal (bad cluster) and caused it to go into full rail limp mode. Blew out the front main seal, lost all its fluid. So I bought it dirt cheap with a blown auto.

Don't EVER drive these long distance with the OD off flashing, it's just a recipe for disaster, and reading the story, probably why yours failed a few times. I don't put the blame on you, I put the blame on ****** mechanics.

I would take it to a transmission shop, not just a basic mechanics shop. I also understand the frustrations of trying to get someone to service a transmission in a mini bus, it's intimidating and no one wants to touch it.
 

BeastMaster

Full Access Member
Joined
Feb 7, 2017
Posts
345
Reaction score
296
Location
Orange, California
Excellent advice!

I consider the E4OD to be a very well designed transmission and tolerated a lot of abuse from errant control solenoid instructions sent from a controller that was fed nonsense.

I consider myself fortunate, or maybe it has a guardian angel?

Mechanics aren't high priests with a magic wand. They do have more experience than most, but are just as vulnerable as the rest of us to the ignorance being enforced by copyrighted and digitally signed electronic codes.

I grew up in a much simpler time where one could get an excellent education in how to fix cars if one cared enough to visit the junkyard and the old cars would teach you. You took them apart, usually several, and from their parts, you reassembled one, gaining both an education and a car.

The process often took years. Longer than it takes to get an MBA. A lesson learned...Respect the Tradesman!

Experience Matters.
 

Rondo

Full Access Member
Joined
Aug 21, 2022
Posts
117
Reaction score
58
Location
Colorado
If you have a way to get it to Precision Transmission in Amarillo, tx they will fix it right. The problem will be getting it there. Look at their YouTube channel for some info on their professionalism.
 

XOLATEM

Full Access Member
Joined
May 5, 2023
Posts
637
Reaction score
812
Location
Virginia... in the brambles
My bet is that the harness connector needs to be replaced with a new one...a pigtail with wires...the repair kit. The connections should be soldered and shielded. I did a few of those...just for good measure and had a helper hold the thing while I soldered it. We had a lift to work on and slid a table underneath to work off of.

I would also run a ground strap from the bellhousing to the battery just to make sure. The torque convertor neck bushing can flake the coating off from arc-ing...especially if it is a babbit bushing.

Looking into the power and grounds through the wiring harness and up to the controller would be prudent...I seem to remember a bulletin long ago about the harness around the top of the case and up to the engine having a problem on some models intermittently. One reason why Ford talks about a "wiggle" test.

All you people are some of the most helpful folks I have ever seen...I am glad to have signed up...hope that I don't need any help but it is good to know that there are some excellent folks out there.

I am sorry you are having all of this trouble but look at all the support you are getting...good luck.
 

danda

Registered User
Joined
May 17, 2022
Posts
72
Reaction score
18
Location
CA
Wow, that's quite a story. sad tale.

Max Mini hasn't posted since Mar 30, a month and a half ago. I hope that means the issue has been resolved.
 
Top