1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

More 7.3 OBS troubles.

Discussion in '7.3L Powerstroke Diesels' started by m67tang, Feb 12, 2020.

  1. m67tang

    m67tang Full Access Member

    Posts:
    492
    Likes Received:
    43
    Joined:
    Oct 13, 2008
    Location:
    lawrenceburg IN
    I rechecked inside the fuel bowl. My bowl heater is unplugged totally. Apparently I bought the truck this way. So I doubt it’s causing my trouble
     
    Last edited: Feb 18, 2020
  2. 79jasper

    79jasper Chickenhawk

    Age:
    27
    Posts:
    16,868
    Likes Received:
    1,679
    Joined:
    Oct 13, 2012
    Location:
    Collinsville, Oklahoma
    There's no definitive answer to that.
    If the ipr is failed completely, you shouldn't get smoke.

    Sent from my SM-N960U using Tapatalk
     
  3. m67tang

    m67tang Full Access Member

    Posts:
    492
    Likes Received:
    43
    Joined:
    Oct 13, 2008
    Location:
    lawrenceburg IN
    A friend came over and helped me get it running....
    I started looking back at what I’ve checked. Not much made sense. I always hear the glow plug relay click on. It’s one of the 1st things I checked. It tested fine. After having it run last night, it wouldn’t start this morning. So I rechecked the GP relay. This time it tested dead! So I jumped it with a screw driver and it fired right up. I turned it off to recheck and it tested just fine. So now it appears my GP relay is playing work/broke with me. Jumping the relay works every time I’ve tried.
    So now a new relay is on the way. Unbelievable.
     
  4. troutwest66

    troutwest66 Ricer-Roni The IDI Treat

    Age:
    54
    Posts:
    594
    Likes Received:
    2
    Joined:
    Jan 13, 2005
    Location:
    Post Falls, Idaho
    The awesome part is you found it and you can sleep at night again! Always a good feeling after fighting something so long and all the frustration.
     
  5. 79jasper

    79jasper Chickenhawk

    Age:
    27
    Posts:
    16,868
    Likes Received:
    1,679
    Joined:
    Oct 13, 2012
    Location:
    Collinsville, Oklahoma
    I've seen a bad gpr cause some weird issues. Basically like they were back feeding to the pcm and shutting it down. Wouldn't start unless disconnecting it.

    Sent from my SM-N960U using Tapatalk
     
  6. greenskeeper

    greenskeeper Full Access Member

    Posts:
    626
    Likes Received:
    75
    Joined:
    Mar 16, 2013
    Location:
    hatfield pa
    Most of the time it is something simple on these trucks.

    I'd take this opportunity to upgrade to the larger stancor relay...and even go one step further to put a 12v LED in the cab wired to the glow plug side of the relay so you can visually see when the plugs are energized.
     
  7. m67tang

    m67tang Full Access Member

    Posts:
    492
    Likes Received:
    43
    Joined:
    Oct 13, 2008
    Location:
    lawrenceburg IN
    That’s what I am getting:Thumbs Up
     
  8. m67tang

    m67tang Full Access Member

    Posts:
    492
    Likes Received:
    43
    Joined:
    Oct 13, 2008
    Location:
    lawrenceburg IN
    Thanks everyone for the help. It kept me going. This ones been difficult. I really need this truck to run for a job next week.
    Thanks!
     
    troutwest66 likes this.
  9. m67tang

    m67tang Full Access Member

    Posts:
    492
    Likes Received:
    43
    Joined:
    Oct 13, 2008
    Location:
    lawrenceburg IN
    128E5563-155C-4AA8-916E-3A645454E668.jpeg 5E33C01F-4EF8-463A-9B93-74A66ECF8376.jpeg Have the new relay in. Also a LED to tell me the GPs are working! F6523686-B394-46DE-AC2E-3E89C65D3729.jpeg
     

Share This Page