intake thump from Ole faithful

Discussion in '6.9L IH & 7.3L IDI Diesels' started by Josh king, Jan 12, 2018 at 11:10 AM.

  1. Josh king

    Josh king Registered User

    Posts:
    5
    Likes Received:
    0
    Joined:
    Thursday
    Location:
    Monterey tn
    Good morning yall! First of all I have been reading on this site for a very long time now and absolutely love it! Just finally decided to become a member last night for some serious help... the Ole 7.3 idi has me stumped...I have a chuffing/poppingish noise from the intake . I originally thought it was a lifter going down causing a valve not to open completely . now not so sure...I have removed all lifters, took them apart, cleaned and replaced them. Still there. None of the lifters seem to pump much oil at idle or higher rpms. Getting frustrated. Double checked the valve guides on passenger intake side couple bad so replaced. Still there...getting good and pissed now. Need some help please. I've also checked injectors as well...I received a donor motor from a buddy that spun a main. So happy for that. Spare parts yes!!!
     
  2. IDIoit

    IDIoit MachinistFabricator Supporting Member

    Posts:
    11,772
    Likes Received:
    1,105
    Joined:
    Aug 26, 2014
    Location:
    commiefornia
    leak down test!!!
    or just pull the heads off your spare engine, have them tested and gone through.
     
  3. Josh king

    Josh king Registered User

    Posts:
    5
    Likes Received:
    0
    Joined:
    Thursday
    Location:
    Monterey tn
    That's where I'm at right now as well. I pulled glow plugs out and shot about 100 psi into the motor and all I managed to do on cylinders 1, 5 and 7 was turn motor over...old heads are off and laying on flatbed. I've pulled couple valves out for S and G. They look good.
     
  4. IDIoit

    IDIoit MachinistFabricator Supporting Member

    Posts:
    11,772
    Likes Received:
    1,105
    Joined:
    Aug 26, 2014
    Location:
    commiefornia
    when im at this point, and im trying to budget things. I pull all the valve springs, dye-chem the valve and seat, let it dry, then put the valve on a drill with some WD-40 and check the pattern.

    any narrow or not taken off dye, I would do a valve job
     
  5. Josh king

    Josh king Registered User

    Posts:
    5
    Likes Received:
    0
    Joined:
    Thursday
    Location:
    Monterey tn
    That sounds like a good idea to me. I've been so frustrated with her That my common sense has momentarily left me for whiskey lol we have a BAD weather front coming our way today so I might just bring the heads into my CB room and start cleaning. Worth a shot
     
  6. 79jasper

    79jasper Chickenhawk

    Age:
    25
    Posts:
    14,277
    Likes Received:
    509
    Joined:
    Oct 13, 2012
    Location:
    Collinsville, Oklahoma
    Before pulling the valves, I would've sprayed in some wd40 or the like down the ports to see if any leak.

    Sent from my SM-G892A using Tapatalk
     
    bbjordan likes this.
  7. Josh king

    Josh king Registered User

    Posts:
    5
    Likes Received:
    0
    Joined:
    Thursday
    Location:
    Monterey tn
    Ah well its gotta be cleaned regardless.

    2018-01-12 19.14.02.jpg
     
  8. Ddizzy77

    Ddizzy77 Registered User

    Posts:
    15
    Likes Received:
    1
    Joined:
    Dec 10, 2017
    Location:
    West
    Just a little crusty...
     
  9. Josh king

    Josh king Registered User

    Posts:
    5
    Likes Received:
    0
    Joined:
    Thursday
    Location:
    Monterey tn
    Just a little lol
     

Share This Page