1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

surging, hesitation

Discussion in '6.9L IH & 7.3L IDI Diesels' started by ulmapache, May 25, 2020.

  1. ulmapache

    ulmapache Registered User

    Posts:
    43
    Likes Received:
    6
    Joined:
    Feb 19, 2020
    Location:
    Reedsport Oregon
    Ok, '84 F250, 2WD, 6.9idi, T19... New front tank, sending unit, switch valve blown out with air... Everything copasetic during normal driving around town, or hiway...however, if I put my foot to the floor after getting into 4th (around 25mph or so)...after a bit, I will get some hesitation and surging...happens on either tank...goes away after a bit of normal driving at hiway speeds. Usually do not go all the way to the floor when accelerating... So...what's the consensus here...fuel lift pump, or IP...or both. Thinking on doing the lift pump first and see it the issue goes away. Less $$ too...IP is a spendy proposition...'specially on a fifteen hundred dollar "go to the dump" truck. Do not want to get stuck with a load of crap on the way to the dump however... Thx for the replies!!!
     
    Selahdoor likes this.
  2. Chief

    Chief Full Access Member

    Posts:
    79
    Likes Received:
    24
    Joined:
    Mar 3, 2019
    Location:
    CLARKSVILLE, TN
    Have you run ATF through your system yet? Could be as simple as crud in your IP, lines, and/or injectors.
     
    Selahdoor likes this.
  3. ulmapache

    ulmapache Registered User

    Posts:
    43
    Likes Received:
    6
    Joined:
    Feb 19, 2020
    Location:
    Reedsport Oregon
    Oh yes...ATF, and Power-serve, and Lucas...fuel system is clean...even had my mechanic do an injector clean-out with some commercial grade cleaner..
     
  4. Greg85

    Greg85 Registered User

    Posts:
    19
    Likes Received:
    11
    Joined:
    Feb 13, 2019
    Location:
    Michigan
    I'm assuming the filter has been changed also, just asking.
     
    ulmapache likes this.
  5. Robm45497

    Robm45497 Registered User

    Posts:
    25
    Likes Received:
    8
    Joined:
    Sep 3, 2016
    Location:
    Mead wa
    4th gear at 25mph, your lugging it to much.
     
  6. Scotty4

    Scotty4 Full Access Member

    Posts:
    413
    Likes Received:
    305
    Joined:
    Nov 15, 2019
    Location:
    Washington
    Toss some hotshots extreme in there and drive it like you stole it. Many had recommended that to me and it worked well. Now every so often I try to run each gear out getting on the highway.
     
  7. Greg85

    Greg85 Registered User

    Posts:
    19
    Likes Received:
    11
    Joined:
    Feb 13, 2019
    Location:
    Michigan
     
  8. Greg85

    Greg85 Registered User

    Posts:
    19
    Likes Received:
    11
    Joined:
    Feb 13, 2019
    Location:
    Michigan
    I just went thru a similar situation with my 92 SD. Occasional surging, sometimes low on power. Put a pressure guage on the filter head- no pressure. Changed the lift pump, back to 5 lbs. Starts better, runs smoother.
     
    Scotty4 likes this.
  9. ulmapache

    ulmapache Registered User

    Posts:
    43
    Likes Received:
    6
    Joined:
    Feb 19, 2020
    Location:
    Reedsport Oregon
    Doing a pump today...will post on results...
     

Share This Page