Left Glow Plug Switch On Fried Something

IDIBRONCO

IDIBRONCO
Joined
Feb 5, 2010
Posts
12,299
Reaction score
11,009
Location
edmond, ks
Want to start by saying thank y'all for all your help. I finally started using my brain yesterday and got it to work. I kept going back to why are the two bolts that are connected to the plastic module housing from the relay getting a charge. So it turns out the relay wasn't grounded properly. When initially taking the old one off and putting the new one on I put the wires exactly where they were before. I thought the fourth port (I) on the relay was for the grounding wire as that's how it was hooked up before. It turns out once I switched that wire to one of the bolts that connect relay to module, it worked first try. So that means the original plastic module that controlled the auto glow plugs had some sort of ground to it and when I left the relay on it no longer functioned that way. I never would have thought it was that since I thought it was just a piece of plastic that had all the wires cut to install manual switch. Anyways it works, momentary switch is installed and I'm living stress free. Thanks again!
I had a 84Mustang with a 3.8 that had TBI on it. It was getting worse about trying to stall when I came to a stop. I thought it had something to do with the throttle body. Finally, a friend and I were riding in it and the engine died when I came to a red light. It wouldn't start so we had to push the car across the intersection. We messed around underneath the hood. He wiggled the starter solenoid and the engine started. One bolt was missing and the solenoid was loose. After work that say, I made a ground wire that ran from the bolt that was still there right to the negative post on the battery. I never had any issues after that. Sometimes they need to be grounded with their own wire, sometimes, like that one, they don't. It had worked fine without a ground wire for a couple of years before it worked loose.
Side note though, high idle rev still isn't working for some reason.
Now you need to see if it's getting power. If it isn't check to see if the plug on top of the sender/switch right underneath the thermostat housing (where the upper radiator hose attaches) is unplugged, loose, or has a bad connection.
 

franklin2

Full Access Member
Joined
Feb 24, 2009
Posts
5,178
Reaction score
1,411
Location
Va
No. It does nothing because one end is connected to the battery positive already. Jumping battery positive to battery positive will do nothing.
It's over now, but I was suspicious his battery feed wire to the glowplug relay was bad, the reason for the jumper.
 

Latest posts

Forum statistics

Threads
91,257
Posts
1,129,304
Members
24,082
Latest member
Bsthomas21
Top