1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

12 valve no top end power

Discussion in '911 Diesel Down!' started by hamptontow, Mar 28, 2019.

  1. hamptontow

    hamptontow Registered User

    Posts:
    7
    Likes Received:
    0
    Joined:
    Mar 28, 2019
    Location:
    hampton ontario canada
    I have a 95 12 valve p pump fn tranny guy said I was over boosting thats why I blew tranny up,because I was running no waste gate, since he touched the truck I have no power on top end she looses power even empty on uphills
     
  2. 79jasper

    79jasper Chickenhawk

    Age:
    26
    Posts:
    16,050
    Likes Received:
    1,304
    Joined:
    Oct 13, 2012
    Location:
    Collinsville, Oklahoma
    Probably turned the pump down. Slide fuel plate and housing back forward, turn star wheel towards engine.

    Sent from my SM-N960U using Tapatalk
     
  3. hamptontow

    hamptontow Registered User

    Posts:
    7
    Likes Received:
    0
    Joined:
    Mar 28, 2019
    Location:
    hampton ontario canada
    fuel plate still sealed never opened star wheel turned abit mild smoke on start but top end nothing
     
  4. 79jasper

    79jasper Chickenhawk

    Age:
    26
    Posts:
    16,050
    Likes Received:
    1,304
    Joined:
    Oct 13, 2012
    Location:
    Collinsville, Oklahoma
    Maybe a pinched fuel line or boost leak then.

    Sent from my SM-N960U using Tapatalk
     
  5. hamptontow

    hamptontow Registered User

    Posts:
    7
    Likes Received:
    0
    Joined:
    Mar 28, 2019
    Location:
    hampton ontario canada
    can you build boost on the guage even with a leak in the system
     
  6. 79jasper

    79jasper Chickenhawk

    Age:
    26
    Posts:
    16,050
    Likes Received:
    1,304
    Joined:
    Oct 13, 2012
    Location:
    Collinsville, Oklahoma
    Yeah, it may just be low.

    Sent from my SM-N960U using Tapatalk
     
  7. hamptontow

    hamptontow Registered User

    Posts:
    7
    Likes Received:
    0
    Joined:
    Mar 28, 2019
    Location:
    hampton ontario canada
    ty i will check boots and fuel lines
     
  8. hamptontow

    hamptontow Registered User

    Posts:
    7
    Likes Received:
    0
    Joined:
    Mar 28, 2019
    Location:
    hampton ontario canada
    I have a 95 cummins 12 valve with a p pump.When driving it will start to tick like a lifter noise then shut off,turn key off restart drive again till you hear the ticking again shove it into nutral coast shut off restart good to go till it happens again.any ideas on this issue.
     
  9. RetiringColt

    RetiringColt Supporting Member Supporting Member

    Posts:
    13
    Likes Received:
    6
    Joined:
    Mar 18, 2019
    Location:
    Washougal WA.
    Hamptontow have you checked your fuel shut off relay and fule shut off solenoid? You may have an intermittent fault in the system. Possibly a bad ground? There is some good YouTube tutorials videos out there for checking that particular fule shut off system. What type of lift pump are you using? Sounds like you are making progress compared to your first post.
     
  10. hamptontow

    hamptontow Registered User

    Posts:
    7
    Likes Received:
    0
    Joined:
    Mar 28, 2019
    Location:
    hampton ontario canada
    lift pump on the block new one been on for 1000 k
     
  11. hamptontow

    hamptontow Registered User

    Posts:
    7
    Likes Received:
    0
    Joined:
    Mar 28, 2019
    Location:
    hampton ontario canada
    not much progress pissed at the no power from this motor ran great till a so called friend mechanic touched it he kept complaining i was over boosting the tranny by not having the waste gate connected i think he did something to detune the truck,i don't trust him we don't talk anymore because of this issue
     

Share This Page