Smokey 7.3 idi in Edmonton

Discussion in 'Introduction' started by Vern, Jul 14, 2018.

  1. Vern

    Vern Registered User

    Posts:
    37
    Likes Received:
    7
    Joined:
    Jul 12, 2018
    Location:
    Albert NB
    Hey all, I recently revived a dusty '91 f250 4x4. It had sit for a year and it was a number of days before getting it going but now its starting up good and reliable. a lot smokey tho. It's my second v8 international (the other was in a thomas bus). its to get in touch with you knowledgeable folks on the International 444 I'm here.

    Got some diesel background. Been doing injector work starting with my Rangers with the Japanese built perkins 2.2 recently got into doing bosch ve pump re-seal jobs. The DB-2 is new territory so is the whole full-size ford truck. I'd like to figure out how to share some videos showing what the truck is doing, sort of a low-load blue smoke right where the accelerator is at the backing-off point.

    things I've done:
    tightened up loose number 1 injector sensor
    re-routed fuel return
    inline 2psi fuel lift pump
    by-passed fuel filter with small inline filter
    new motorcraft thermostat
    Replaced CDR with street vent


    Looking forward to getting into it with you all.

    IMG_2444.JPG
     
  2. DaveBen

    DaveBen Supporting Member Supporting Member

    Age:
    69
    Posts:
    1,242
    Likes Received:
    197
    Joined:
    Sep 29, 2010
    Location:
    Ukiah, Ca
    Welcome to Oil Burners Vern! :Thumbs Up
     
  3. Jason1377

    Jason1377 Supporting Member Supporting Member

    Posts:
    424
    Likes Received:
    132
    Joined:
    Dec 12, 2017
    Location:
    Arkansas
    Welcome to oilburners land of guru people that are like family
     
  4. Button9595

    Button9595 Registered User

    Posts:
    5
    Likes Received:
    0
    Joined:
    May 9, 2018
    Location:
    Black diamond, WA
    I just had this same sort of thing happening with my 7.3 after it was working a little harder than usual, such as going over a mountain pass. I threw in a new air filter and it hasn't done it since! Took me by surprise that that's all it was. (I hope)
     

Share This Page