1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

surging at road speed, more noticable with cruise on

Discussion in '7.3L Powerstroke Diesels' started by compressionignitionrules, Nov 20, 2020.

  1. compressionignitionrules

    compressionignitionrules Full Access Member

    Posts:
    786
    Likes Received:
    252
    Joined:
    May 1, 2016
    Location:
    Bluevale ON
    my 96 F250 2wd 7.3 E4OD. feels like its boost and then no boost, I never hear the turbo so I'm not really sure. mostly highway commute to work 45 min each way. no codes or engien light. it soemtimes starts and stalls with cold starts, but if I give it a wee bit of throttle on those starts its fine. has lots of miles on it, stock as far as I can tell. idle is soemtimes erratic but temp doesn't seem to make any difference. great on fuel and lots of power, and no engien light. i am suspecting my icp sensor or maybe soemthing with the exhaust backpressure sensor. any other ideas. i realize this might be a shot because of no engien light. thansk in advance for input/opinions. cheers James

    oh yeah aprox 385,000 miles, or around 620,000 km 106297528_192466272193632_4497628392870111677_n.jpg
     
  2. 79jasper

    79jasper Chickenhawk

    Age:
    28
    Posts:
    17,206
    Likes Received:
    1,802
    Joined:
    Oct 13, 2012
    Location:
    Collinsville, Oklahoma
    With the psd (or any engine really) i still advise scanning for codes, even with no apparent light. You just may find something.
    Icp sensor is a good starting point. You've ruled out the TPS/APPS by still acting up with cruise engaged.
    The ebpv and ebps could be a issue, but wouldn't cause the stall.

    Sent from my SM-G988U using Tapatalk
     
  3. dsrace

    dsrace sand toys

    Posts:
    116
    Likes Received:
    1
    Joined:
    Sep 20, 2009
    Location:
    valparaiso ne
    watch your tps on the scanner. you will need a scanner to view live data or wait till what ever fails altogether.
     
  4. compressionignitionrules

    compressionignitionrules Full Access Member

    Posts:
    786
    Likes Received:
    252
    Joined:
    May 1, 2016
    Location:
    Bluevale ON
    I don't have a scanner, bought a programmer but it turns out it only works on 7.3 in superduty. but it does read codes. nothign has showed up yet using the read option. thanks for the ideas guys.
     
  5. greenskeeper

    greenskeeper Full Access Member

    Posts:
    744
    Likes Received:
    93
    Joined:
    Mar 16, 2013
    Location:
    hatfield pa
    What is your fuel pressure at idle? under load?

    Has the regulator ever been rebuilt? Has the screen at the regulator been cleaned?
     
  6. compressionignitionrules

    compressionignitionrules Full Access Member

    Posts:
    786
    Likes Received:
    252
    Joined:
    May 1, 2016
    Location:
    Bluevale ON
    I don't have scanner only code reader. on satruday i hauled my trailer and load , around 6000lbs behind the truck and did not notice any surging, . it surprised me, cruise on or off seemed to make no difference. rpms were in the 1500-2000 rpm range . no passing , easy acceleration from stop when I'm towing > hate to waste the fuel.
     
  7. compressionignitionrules

    compressionignitionrules Full Access Member

    Posts:
    786
    Likes Received:
    252
    Joined:
    May 1, 2016
    Location:
    Bluevale ON
    ok I've run it a few days with the connector to the turbo unplugged, surging is gone and way more passing power. still need an icp sensor as its hard start and rough idle but at least one problem is cleared up. still no engine lite staying on. I think my fuel economy has improved too, but warm up is definitely affected. below freezing temps at night make for not much heat now .
     

Share This Page