1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Orange engine warning light stays on

Discussion in '7.3L Powerstroke Diesels' started by fraree, Jun 12, 2019.

  1. fraree

    fraree Full Access Member

    Posts:
    106
    Likes Received:
    29
    Joined:
    Nov 18, 2013
    Location:
    Inland. Australia
    Since I've restarted & been running my truck after doing the injector sleeves etc plus the water pump & oilcooler the orange engine warning light has stayed illuminated once the engine is running.
    Replaced the oil pressure sensor on top of the Hpop reservoir. The engine oil pressure gauge is working fine. The only code which comes up is PO237 which is a "turbo input low"
    Going a towing trip in 10 days, hope to sort out what up before then !
     
  2. 79jasper

    79jasper Chickenhawk

    Age:
    26
    Posts:
    16,139
    Likes Received:
    1,331
    Joined:
    Oct 13, 2012
    Location:
    Collinsville, Oklahoma
    Saw other thread first. Replace the map sensor.
    Also check the icp sensor for oil. (The one to the driver side of the hpop)

    Sent from my SM-N960U using Tapatalk
     
  3. fraree

    fraree Full Access Member

    Posts:
    106
    Likes Received:
    29
    Joined:
    Nov 18, 2013
    Location:
    Inland. Australia
    Thanks 79Jasper. My truck has been converted to RH drive, so you're referring to the left side of the engine bay. I've found a connection which looks like it would fit the map sensor but I cannot remember ever seeing a map sensor (connection as shown) As this is a RH drive conversion done in Australia things are in different locations. map sensor 0.jpg Can't see an air hose/pipe which would have connected either. I replaced the 2 sensors next to hpop 5k klm (2400m) ago.
     
  4. 79jasper

    79jasper Chickenhawk

    Age:
    26
    Posts:
    16,139
    Likes Received:
    1,331
    Joined:
    Oct 13, 2012
    Location:
    Collinsville, Oklahoma
    What year? Yours appears to be a 99+?
    Ah, yes. Complicates things a bit.
    The intake plenums (under the y that is connected to the turbo) you should find a nipple and hose coming off the RH side (your driver side) about midway. Pretty much next to where the y connects.
    [​IMG]

    Sent from my SM-N960U using Tapatalk
     
  5. fraree

    fraree Full Access Member

    Posts:
    106
    Likes Received:
    29
    Joined:
    Nov 18, 2013
    Location:
    Inland. Australia
    Yes good guess '99 1/2. came out as an incomplete vehicle (cab chasis). I'll do some investigation now its morning here :Thumbs Up
     
  6. fraree

    fraree Full Access Member

    Posts:
    106
    Likes Received:
    29
    Joined:
    Nov 18, 2013
    Location:
    Inland. Australia
    map sensor.jpg Thanks for the place to start.Traced the hose off the Y :rolleyes: was pushed over the back. Scored a new job which required an imeadiate start hence a rush to finish:eek: I took months to do my injector cups etc with working away from home a few times during the job. Picking up from where you left off is always an issue. Feel like a "Goose" (Australian slang)
    Another reason I use the forum so much. Thanks heaps :Thumbs Up :cheers:
     
  7. fraree

    fraree Full Access Member

    Posts:
    106
    Likes Received:
    29
    Joined:
    Nov 18, 2013
    Location:
    Inland. Australia
    Plugged it back in, the light is still on, so back to the original plan, new map sensor by the look of it. Did a code check, 603 & 237 came up, cleared them. Will see how it pans out when the new sensor arrives.
     
  8. 79jasper

    79jasper Chickenhawk

    Age:
    26
    Posts:
    16,139
    Likes Received:
    1,331
    Joined:
    Oct 13, 2012
    Location:
    Collinsville, Oklahoma
    The vacuum pump gave it away. Lol

    Sent from my SM-N960U using Tapatalk
     
  9. fraree

    fraree Full Access Member

    Posts:
    106
    Likes Received:
    29
    Joined:
    Nov 18, 2013
    Location:
    Inland. Australia
    Just went & started the truck after leaving it for a while with the batteries disconnected & the "liitle green men" who hide in the electrical system must be happy once more. Orange engine light switched itself off how it should do!:Thumbs Up
     
  10. 79jasper

    79jasper Chickenhawk

    Age:
    26
    Posts:
    16,139
    Likes Received:
    1,331
    Joined:
    Oct 13, 2012
    Location:
    Collinsville, Oklahoma
    Sometimes can take a bit, unless you do it with a code reader. Not a lot of them will talk the right language for these trucks.

    Sent from my SM-N960U using Tapatalk
     
  11. fraree

    fraree Full Access Member

    Posts:
    106
    Likes Received:
    29
    Joined:
    Nov 18, 2013
    Location:
    Inland. Australia
    All good now, happy days
     
  12. 79jasper

    79jasper Chickenhawk

    Age:
    26
    Posts:
    16,139
    Likes Received:
    1,331
    Joined:
    Oct 13, 2012
    Location:
    Collinsville, Oklahoma
    If you are interested in any extra power, look up the hydra. I would get it from 1023 or jelibuilt.

    Sent from my SM-N960U using Tapatalk
     
  13. fraree

    fraree Full Access Member

    Posts:
    106
    Likes Received:
    29
    Joined:
    Nov 18, 2013
    Location:
    Inland. Australia
    Thanks but I already have "safe tow" tune in from my Superchips 1705 tuner. I inherited it from a family member. I know it's old but the price was right & it does the job.
     
  14. 79jasper

    79jasper Chickenhawk

    Age:
    26
    Posts:
    16,139
    Likes Received:
    1,331
    Joined:
    Oct 13, 2012
    Location:
    Collinsville, Oklahoma
    Ah, I see. Were some companies still doing real tuning for those, but they may have stopped now.

    Sent from my SM-N960U using Tapatalk
     

Share This Page