no start

Discussion in '5.9L 24 valve Cummins' started by no mufflers, Aug 12, 2017.

  1. no mufflers

    no mufflers Supporting Member Supporting Member

    Age:
    23
    Posts:
    1,394
    Likes Received:
    364
    Joined:
    Jan 20, 2014
    Location:
    rhode island
    I have a friends truck, its a 99 and he was driving it and the gauges went wonky on him and the truck shut off and wont start now. it cranks over fine with plenty of speed but just wont fire. I am having him tow it to my shop so I can scan it to check for codes. all the fuses seem to be good and the fuel pump on the back driver side of the motor is running, I have not check for fuel pressure from that yet. that could be a problem but what I am very unfamiliar with is the electronic parts on the engine.

    im not sure if there are any parts to check for voltage on the injection pump or anything else that can be problematic. I know this section doesn't get much traffic but any help would be great.
     
  2. 79jasper

    79jasper Chickenhawk

    Age:
    24
    Posts:
    13,288
    Likes Received:
    218
    Joined:
    Oct 13, 2012
    Location:
    Collinsville, Oklahoma
    Maybe check the fuel shut off solenoid.
    Offhand I can't say how.

    Sent from my SAMSUNG-SM-G890A using Tapatalk
     
  3. rustygold

    rustygold Full Access Member

    Posts:
    413
    Likes Received:
    32
    Joined:
    Feb 19, 2015
    Location:
    conway Arkansas
    I would agree with jasper. Cummins had a 3 to 4 year of running a V pump for common rail. Is she reading rpms? That year model dodge had bad pcm even cummins has there own computer. See what codes it pulls up and let us know.

    Sent from my SAMSUNG-SM-G870A using Tapatalk
     
  4. no mufflers

    no mufflers Supporting Member Supporting Member

    Age:
    23
    Posts:
    1,394
    Likes Received:
    364
    Joined:
    Jan 20, 2014
    Location:
    rhode island
    Thanks guys. I'll have it tomorrow so I'll report back then.
     
  5. no mufflers

    no mufflers Supporting Member Supporting Member

    Age:
    23
    Posts:
    1,394
    Likes Received:
    364
    Joined:
    Jan 20, 2014
    Location:
    rhode island
    the picture says it all........ a ford doing what fords do, towing broken dodges. LOL

    IMG_20170813_111208.jpg


    back to the topic.... I do get some RPMs while cranking. the two pictures are the codes. the first pic is when I first plugged it in and the second pic is after I cleared the first set of codes and tried to start it again.



    IMG_20170813_114117.jpg

    IMG_20170813_115005.jpg
     
  6. rustygold

    rustygold Full Access Member

    Posts:
    413
    Likes Received:
    32
    Joined:
    Feb 19, 2015
    Location:
    conway Arkansas
    I would say injection pump here's the testing for it.[​IMG][​IMG][​IMG]

    Sent from my SAMSUNG-SM-G870A using Tapatalk
     
    no mufflers and 79jasper like this.
  7. no mufflers

    no mufflers Supporting Member Supporting Member

    Age:
    23
    Posts:
    1,394
    Likes Received:
    364
    Joined:
    Jan 20, 2014
    Location:
    rhode island
    Cool thanks, I have a feeling this won't be a cheap fix...
     
  8. rustygold

    rustygold Full Access Member

    Posts:
    413
    Likes Received:
    32
    Joined:
    Feb 19, 2015
    Location:
    conway Arkansas
    That pump if I do remember right has to be timed still.

    Sent from my SAMSUNG-SM-G870A using Tapatalk
     
  9. no mufflers

    no mufflers Supporting Member Supporting Member

    Age:
    23
    Posts:
    1,394
    Likes Received:
    364
    Joined:
    Jan 20, 2014
    Location:
    rhode island
    Are there any other indications if it could be a computer problem? If it ends up being a pump is there a good and bad brand? Would it be worth an upgrade? My scanner is a new verus edge but I'm not set up with shop key yet.
     
  10. rustygold

    rustygold Full Access Member

    Posts:
    413
    Likes Received:
    32
    Joined:
    Feb 19, 2015
    Location:
    conway Arkansas
    Most of the time if everything test in specs then pcm is a bad.

    Sent from my SAMSUNG-SM-G870A using Tapatalk
     
  11. 79jasper

    79jasper Chickenhawk

    Age:
    24
    Posts:
    13,288
    Likes Received:
    218
    Joined:
    Oct 13, 2012
    Location:
    Collinsville, Oklahoma
    Any chance theres a power adder on it?

    Sent from my SAMSUNG-SM-G890A using Tapatalk
     
  12. no mufflers

    no mufflers Supporting Member Supporting Member

    Age:
    23
    Posts:
    1,394
    Likes Received:
    364
    Joined:
    Jan 20, 2014
    Location:
    rhode island

    I think it has a real early banks upgrade kit. Not entirely sure what that involves on the 24v. The first owner said he used to blow off the boost tube on the intake horn so he kept an extra one on hand. The truck only has 120,000 on it but was worked hard.
     
  13. 79jasper

    79jasper Chickenhawk

    Age:
    24
    Posts:
    13,288
    Likes Received:
    218
    Joined:
    Oct 13, 2012
    Location:
    Collinsville, Oklahoma
    Its possible it could have a tuner of some sort.
    Banks ones are known to fry computers.

    Sent from my SAMSUNG-SM-G890A using Tapatalk
     
  14. no mufflers

    no mufflers Supporting Member Supporting Member

    Age:
    23
    Posts:
    1,394
    Likes Received:
    364
    Joined:
    Jan 20, 2014
    Location:
    rhode island
    Well I guess I'll find out tomorrow. The first owner also said this truck had a hard time pulling his construction trailer with what he had on it. I find that hard to believe with the boost that was being made.

    The other thing I noticed is the TC never goes into full lockup, the ABS and brake light come on and off. I scanned it before and the codes go all over the place, like Chang in a matter of seconds.
     
  15. rustygold

    rustygold Full Access Member

    Posts:
    413
    Likes Received:
    32
    Joined:
    Feb 19, 2015
    Location:
    conway Arkansas
    The TC brake light has to do with the brake switch. I have ran into problem on one truck guy didn't care if it was fixed or not. He said it stays on the farm and never leave unless needs to be fixed.

    Sent from my SAMSUNG-SM-G870A using Tapatalk
     

Share This Page