1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New to the 6.0 have injector issues.

Discussion in '6.0L Powerstroke Diesels' started by Josh Oldenburg, Jun 11, 2019.

  1. Josh Oldenburg

    Josh Oldenburg Full Access Member

    Age:
    35
    Posts:
    144
    Likes Received:
    19
    Joined:
    Apr 16, 2017
    Location:
    Baileyville IL
    Working on a customer's '05 6.0. he bought it not running and wanted me to look at it. Turns out it was out of fuel so I added 9 gallons finally got it to fire but it's missing. When I first got it the fire it wouldn't rev easily tons of black smoke at idle. Once I got it to clean out it will Rev but hesitates and doing so I have done a buzz test and a contribution test and a glow plug test. I'm thinking it needs a set of injectors, glow plugs, and both fuel filters. Am I wrong? Can't upload the video of the contribution test but number one was -25 and number 8 was -80. [​IMG][​IMG][​IMG][​IMG]

    Sent from my Pixel 3 XL using Tapatalk
     
  2. snicklas

    snicklas 6.0 and Loving It!! Staff Member

    Age:
    45
    Posts:
    5,285
    Likes Received:
    1,186
    Joined:
    Aug 7, 2006
    Location:
    Greenfield, Indiana
    I would do both fuel filters, motorcraft only! I would also check the FICM. All 8 low could be a dying FICM.

    On thing I’ve noticed between the IDI and 6.0, the 6.0 free revs much slower than any IDI. An IDI just ”jumps up” when you hit the throttle. The 6.0 being computer controlled winds up.....
     
    Oledirtypearl86 likes this.
  3. Josh Oldenburg

    Josh Oldenburg Full Access Member

    Age:
    35
    Posts:
    144
    Likes Received:
    19
    Joined:
    Apr 16, 2017
    Location:
    Baileyville IL
    I looked into that but didn't know what I was looking at. I can look at all the voltages when I'm in it with my scan tool what indicates a bad one. and those were all the engine codes when I first got the vehicle. I did a cylinder balance test and number eight was a dead cylinder and number one was a week cylinder. All the rest sounded good.

    Sent from my Pixel 3 XL using Tapatalk
     
  4. hoodshauler

    hoodshauler Full Access Member

    Age:
    54
    Posts:
    651
    Likes Received:
    100
    Joined:
    Jan 21, 2005
    Location:
    PARKER, CO
    FICM voltage should be 48 volts


    Sent from my iPhone using Tapatalk
     
  5. Josh Oldenburg

    Josh Oldenburg Full Access Member

    Age:
    35
    Posts:
    144
    Likes Received:
    19
    Joined:
    Apr 16, 2017
    Location:
    Baileyville IL
    There were several voltage readings. Are they all supposed to be 48 volts?

    Sent from my Pixel 3 XL using Tapatalk
     
  6. hoodshauler

    hoodshauler Full Access Member

    Age:
    54
    Posts:
    651
    Likes Received:
    100
    Joined:
    Jan 21, 2005
    Location:
    PARKER, CO
    None of the fcim readings should be below 47.5 as i understand it


    Sent from my iPhone using Tapatalk
     
    DaveBen likes this.
  7. Josh Oldenburg

    Josh Oldenburg Full Access Member

    Age:
    35
    Posts:
    144
    Likes Received:
    19
    Joined:
    Apr 16, 2017
    Location:
    Baileyville IL
    I will double check when I get back to the truck.

    Sent from my Pixel 3 XL using Tapatalk
     
  8. Josh Oldenburg

    Josh Oldenburg Full Access Member

    Age:
    35
    Posts:
    144
    Likes Received:
    19
    Joined:
    Apr 16, 2017
    Location:
    Baileyville IL
    I thought I saw some that were reading 24.5

    Sent from my Pixel 3 XL using Tapatalk
     
  9. hoodshauler

    hoodshauler Full Access Member

    Age:
    54
    Posts:
    651
    Likes Received:
    100
    Joined:
    Jan 21, 2005
    Location:
    PARKER, CO
    Im on the road or i would send you a link to the article on testing the ficm. You can google it and get all the info


    Sent from my iPhone using Tapatalk
     
  10. snicklas

    snicklas 6.0 and Loving It!! Staff Member

    Age:
    45
    Posts:
    5,285
    Likes Received:
    1,186
    Joined:
    Aug 7, 2006
    Location:
    Greenfield, Indiana
  11. Oledirtypearl86

    Oledirtypearl86 Full Access Member

    Age:
    33
    Posts:
    899
    Likes Received:
    438
    Joined:
    Sep 17, 2018
    Location:
    Whitehall MT
    So I just changed jobs and I'm working at a small shop where I live and we had a similar situation with a 6.0 and as I was checking everything I put a charger on the batteries an the ficm voltage was low changed the ficm and still ran a little rough changed both fuel filters and took it for a good rip down the road still just a bit rough but much better did a oil service with motocraft filter also and oil and it cleared right up
     
  12. 79jasper

    79jasper Chickenhawk

    Age:
    26
    Posts:
    16,139
    Likes Received:
    1,331
    Joined:
    Oct 13, 2012
    Location:
    Collinsville, Oklahoma
    For sure start with filters. Including a oil change with a motorcraft filter and cap as well. (I would recommend 5w-40 synthetic)
    Then I would make sure all the air is worked out.
    It is possible that it needs injectors. Not all that uncommon.

    Sent from my SM-N960U using Tapatalk
     
  13. Josh Oldenburg

    Josh Oldenburg Full Access Member

    Age:
    35
    Posts:
    144
    Likes Received:
    19
    Joined:
    Apr 16, 2017
    Location:
    Baileyville IL
    Thanks guys

    Sent from my Pixel 3 XL using Tapatalk
     
  14. Josh Oldenburg

    Josh Oldenburg Full Access Member

    Age:
    35
    Posts:
    144
    Likes Received:
    19
    Joined:
    Apr 16, 2017
    Location:
    Baileyville IL
    Went to go check the ficm and found the reservoir was over pressurized. When I relieved the pressure I heard air rushing from the block and the reservoir was empty of fluid. I am suspecting a blown head gasket

    Sent from my Pixel 3 XL using Tapatalk
     
  15. Josh Oldenburg

    Josh Oldenburg Full Access Member

    Age:
    35
    Posts:
    144
    Likes Received:
    19
    Joined:
    Apr 16, 2017
    Location:
    Baileyville IL
    Yup system over pressure. saw it spike to 20 psi and the coolant all over the engine bay
     

Share This Page