1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

injector smoke / truck died while driving / rebuilt injectors / wont refire

Discussion in '911 Diesel Down!' started by slam1, Jul 6, 2019.

  1. slam1

    slam1 Full Access Member

    Age:
    52
    Posts:
    78
    Likes Received:
    1
    Joined:
    Jun 11, 2007
    Location:
    Sarasota FL
    Man................. Does it really take this long to get the air out?????? Holy smoke! I actually got it to run briefly last night but it didnt run to well. Back to the shop this morning to see if this thing will run. Seriously, is there any way to cut down on the cranking time if I ever have to do this again?
     
  2. 79jasper

    79jasper Chickenhawk

    Age:
    26
    Posts:
    16,265
    Likes Received:
    1,377
    Joined:
    Oct 13, 2012
    Location:
    Collinsville, Oklahoma
    You could make some adapters to use a porta power filled with engine oil and pump in through the icp hole (or one of the other ports) but will still need cranking.

    Sent from my SM-N960U using Tapatalk
     
  3. slam1

    slam1 Full Access Member

    Age:
    52
    Posts:
    78
    Likes Received:
    1
    Joined:
    Jun 11, 2007
    Location:
    Sarasota FL
    The service engine soon light stays on while I'm cranking..... Is this an issue?
     
  4. 79jasper

    79jasper Chickenhawk

    Age:
    26
    Posts:
    16,265
    Likes Received:
    1,377
    Joined:
    Oct 13, 2012
    Location:
    Collinsville, Oklahoma
    While cranking, I don't believe so. Goes off with key on?

    Sent from my SM-N960U using Tapatalk
     
  5. slam1

    slam1 Full Access Member

    Age:
    52
    Posts:
    78
    Likes Received:
    1
    Joined:
    Jun 11, 2007
    Location:
    Sarasota FL
    No, does not go off at all.
     
  6. slam1

    slam1 Full Access Member

    Age:
    52
    Posts:
    78
    Likes Received:
    1
    Joined:
    Jun 11, 2007
    Location:
    Sarasota FL
    Now it seems like it's not trying to fire, just spins over quickly.
     
  7. Thewespaul

    Thewespaul Supporting Vendor Supporting Member

    Posts:
    7,191
    Likes Received:
    5,217
    Joined:
    Jul 27, 2015
    Location:
    Bulverde, Texas
    Pull the codes, you got something else going on
     
  8. slam1

    slam1 Full Access Member

    Age:
    52
    Posts:
    78
    Likes Received:
    1
    Joined:
    Jun 11, 2007
    Location:
    Sarasota FL
    No codes. Could be my crappy code reader. It tries on the initial hit but nothing after the first 3 seconds.
     
  9. 79jasper

    79jasper Chickenhawk

    Age:
    26
    Posts:
    16,265
    Likes Received:
    1,377
    Joined:
    Oct 13, 2012
    Location:
    Collinsville, Oklahoma
    If it stays on like that, definitely a code.

    Sent from my SM-N960U using Tapatalk
     
  10. slam1

    slam1 Full Access Member

    Age:
    52
    Posts:
    78
    Likes Received:
    1
    Joined:
    Jun 11, 2007
    Location:
    Sarasota FL
    Went and bought a decent code reader and it won't connect to my truck. FML! Truck started but ran like only two injectors were working. Full throttle was 750 rpm. Now it just turns over quickly again. There's no way it should take this long.
     
  11. 79jasper

    79jasper Chickenhawk

    Age:
    26
    Posts:
    16,265
    Likes Received:
    1,377
    Joined:
    Oct 13, 2012
    Location:
    Collinsville, Oklahoma
    It may still have air, but could be the uvch or idm. I would still pull the idm and shake it

    Sent from my SM-N960U using Tapatalk
     
  12. slam1

    slam1 Full Access Member

    Age:
    52
    Posts:
    78
    Likes Received:
    1
    Joined:
    Jun 11, 2007
    Location:
    Sarasota FL
    I'll check the IDM. The UVCH is the harness built into the valve cover gaskets? If so they are new and securely plugged in.
     
  13. 79jasper

    79jasper Chickenhawk

    Age:
    26
    Posts:
    16,265
    Likes Received:
    1,377
    Joined:
    Oct 13, 2012
    Location:
    Collinsville, Oklahoma
    Those are the ones. What brand were they? Some have been known to be bad right out of the box. (Dorman, probably others as well)

    Sent from my SM-N960U using Tapatalk
     
  14. slam1

    slam1 Full Access Member

    Age:
    52
    Posts:
    78
    Likes Received:
    1
    Joined:
    Jun 11, 2007
    Location:
    Sarasota FL
    Yes I think they were. Got em at O'Reilly's. Can I check them with a test light while turning it over? or is there a better way?
     
  15. 79jasper

    79jasper Chickenhawk

    Age:
    26
    Posts:
    16,265
    Likes Received:
    1,377
    Joined:
    Oct 13, 2012
    Location:
    Collinsville, Oklahoma

Share This Page