Electric issues 93 6.5

Discussion in '6.5L Diesels' started by GunnerJ, Jan 3, 2017.

  1. GunnerJ

    GunnerJ Full Access Member

    Posts:
    100
    Likes Received:
    1
    Joined:
    Sep 7, 2015
    Location:
    Western Idaho
    I ended up trading into a 6.5, and overall I'm pleased. There is a big issue with the wiring however (I believe). When it's been sitting overnight, it blows a guage fuse without fault. When I put it in reverse, my panel lights and radio and sometimes even my blower controls flicker. Sometimes my glow plugs randomly come on, even after a half hour of running. Bumps cause things to flicker as well. When I turn my headlights on, sometimes it takes 10 or 15 seconds to get them to light up, and my panel lights are about the same but never come on at the same time. It seems like it would be a body control module or PCM, but a Google search brings nothing up. Anyone have experience with an issue like this or any suggestions?

    Sent from my VS987 using Tapatalk
     
  2. 79jasper

    79jasper Chickenhawk

    Age:
    24
    Posts:
    13,202
    Likes Received:
    190
    Joined:
    Oct 13, 2012
    Location:
    Collinsville, Oklahoma
    Well you didn't say what year, but there's no body control module.
    Sounds like you just need to start checking the wiring.

    Sent from my SAMSUNG-SM-G935A using Tapatalk
     
  3. GunnerJ

    GunnerJ Full Access Member

    Posts:
    100
    Likes Received:
    1
    Joined:
    Sep 7, 2015
    Location:
    Western Idaho
    I was not hoping to hear that, its a 93

    Sent from my VS987 using Tapatalk
     
  4. 79jasper

    79jasper Chickenhawk

    Age:
    24
    Posts:
    13,202
    Likes Received:
    190
    Joined:
    Oct 13, 2012
    Location:
    Collinsville, Oklahoma
    And check all the grounds.
    Swap the relays too.

    Sent from my SAMSUNG-SM-G935A using Tapatalk
     
  5. GunnerJ

    GunnerJ Full Access Member

    Posts:
    100
    Likes Received:
    1
    Joined:
    Sep 7, 2015
    Location:
    Western Idaho
    Oh boy. Thank you, I'll start there

    Sent from my VS987 using Tapatalk
     

Share This Page