1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

bad PCM?

Discussion in '5.9L 24 valve Cummins' started by no mufflers, Jan 12, 2019 at 11:42 AM.

  1. no mufflers

    no mufflers Supporting Member Supporting Member

    Age:
    24
    Posts:
    1,974
    Likes Received:
    822
    Joined:
    Jan 20, 2014
    Location:
    rhode island
    on my 98 i just finished doing some work on it and did some wire harness cleanup. so the problem i am having is the trans wont shift on its own. everything worked fine before i did all this work. i have a cs2 in the truck and in any gear it says 1st and if you try to drive it it says its shifting gears but mechanically nothing is happening.

    i am getting two codes p1698 and p0606. according to my snapon scanner those basically mean check engine light malfunction and bad PCM/ECM. i can get communication with everything but the body.
     
  2. Oledirtypearl86

    Oledirtypearl86 Full Access Member

    Age:
    33
    Posts:
    456
    Likes Received:
    216
    Joined:
    Sep 17, 2018
    Location:
    Whitehall MT
    Did you mess with any wiring connected to the trans also is there any fuses for the trans
     
  3. no mufflers

    no mufflers Supporting Member Supporting Member

    Age:
    24
    Posts:
    1,974
    Likes Received:
    822
    Joined:
    Jan 20, 2014
    Location:
    rhode island
    Yes I basically had the whole truck/body/trans harness out. I didn't touch the engine harness besides unplugging it from the fuse block. Fuses and relays seem to be good.

    I did some more digging with my scanner and it basically listed the p1693 as a dealer specific code. I really don't think I messed up any wires but I haven't ruled it out since I did have it all apart.

    I think I can go to a Cummins dealer and get the ECM tested but the truck runs fine so that's why i'm leaning towards the pcm .

    And like I mentioned my scanner has an option to read the body but I can't communicate with it.
     
    Oledirtypearl86 likes this.
  4. Oledirtypearl86

    Oledirtypearl86 Full Access Member

    Age:
    33
    Posts:
    456
    Likes Received:
    216
    Joined:
    Sep 17, 2018
    Location:
    Whitehall MT
    I hate wiring nothing ever seens to go back to normal but I talked to a buddy of mine last night over a few beers he is a Dodge tech in Bozeman he said a p1693 is a generic for something happened but isn't any more and said what they usually do is clear all The codes and run it againe see if it will come back up if it does your able to read the trouble code not the generic
     
    no mufflers likes this.
  5. no mufflers

    no mufflers Supporting Member Supporting Member

    Age:
    24
    Posts:
    1,974
    Likes Received:
    822
    Joined:
    Jan 20, 2014
    Location:
    rhode island
    yes i can clear codes and the p1693 will come right back along with the p0606 code. i will add the wait to start light is delayed to come on when the key is turned but its always done this.

    ive been reaching a lot and its all pointing to a bad PCM or ECM. i read i can take the ECM to a cummins dealer and they can test it. im just trying to figure it out before i start sending out computers or buying new ones.

    i have a local dodge dealer i can take it to to maybe do something with it but i would have to trailer it cause it wont shift due to something electronic.
     
  6. Oledirtypearl86

    Oledirtypearl86 Full Access Member

    Age:
    33
    Posts:
    456
    Likes Received:
    216
    Joined:
    Sep 17, 2018
    Location:
    Whitehall MT
    What does the p0606 come back as
     
  7. no mufflers

    no mufflers Supporting Member Supporting Member

    Age:
    24
    Posts:
    1,974
    Likes Received:
    822
    Joined:
    Jan 20, 2014
    Location:
    rhode island
    20190113_145659.jpg

    i figured it would be good to fix up the wiring while doing the HG and it leaves me with this :frustrate:kick::smash:
     
  8. Oledirtypearl86

    Oledirtypearl86 Full Access Member

    Age:
    33
    Posts:
    456
    Likes Received:
    216
    Joined:
    Sep 17, 2018
    Location:
    Whitehall MT
    Yeah that is a kick in the junk I still think a wiring issue if it was running good before I don't see a new bit of wiring frying a pcm
     
    no mufflers likes this.
  9. Thewespaul

    Thewespaul Supporting Vendor Supporting Member

    Posts:
    5,758
    Likes Received:
    3,695
    Joined:
    Jul 27, 2015
    Location:
    Bulverde, Texas
    Did you disconnect the batteries before disconecting the harnesses? I’d double check each of the connections to make sure that’s not your communication issue
     
  10. no mufflers

    no mufflers Supporting Member Supporting Member

    Age:
    24
    Posts:
    1,974
    Likes Received:
    822
    Joined:
    Jan 20, 2014
    Location:
    rhode island
    Yeah I took the batteries out before I did anything. If I run the truck and watch my tuner display the gear selection will sometimes show or flash neutral even tho it's in park. The truck computer seems to always think it's in 1st.
     
  11. Crawler

    Crawler Supporting Member Supporting Member

    Posts:
    159
    Likes Received:
    47
    Joined:
    Oct 13, 2018
    Location:
    Dallas, TX
    I’d concentrate on the transmission connector first. Check all of the wires and the pins on the VB.

    I would recommended ohming the wires from the connector to the ecm plug.
     
    no mufflers and Oledirtypearl86 like this.

Share This Page