94 7.3 idi blowing white smoke at 1500 rpm with no power

Discussion in '6.9L IH & 7.3L IDI Diesels' started by Danish1965, Aug 11, 2018.

  1. Danish1965

    Danish1965 Registered User

    Posts:
    7
    Likes Received:
    0
    Joined:
    Mar 26, 2018
    Location:
    Oregon
    This is my first time on the forum. I recently purchased a 94 f350 turbo 7.3 idi. I replaced the injectors and changed the oil. Today I started the truck and it was running fine. Revved the motor and it suddenly started blowing white smoke and running rough at 1500 rpm. No coolant lost. Help????
     
  2. Thewespaul

    Thewespaul Supporting Member Supporting Member

    Posts:
    4,151
    Likes Received:
    2,147
    Joined:
    Jul 27, 2015
    Location:
    Bulverde, Texas
    Welcome to the forum, where did you get the injectors? Did it run fine when you first started it with the new injectors?
     
  3. Danish1965

    Danish1965 Registered User

    Posts:
    7
    Likes Received:
    0
    Joined:
    Mar 26, 2018
    Location:
    Oregon
    It did. The truck is parked and I am restoring it
     
  4. Jason1377

    Jason1377 Supporting Member Supporting Member

    Posts:
    375
    Likes Received:
    122
    Joined:
    Dec 12, 2017
    Location:
    Arkansas
    Mine does that some time depends on where I got got the fuel n I have new gp's injectors was replaced 60k ago before I got the truck does it on start up once many twice a week depending on where I get fuel
     
  5. Thewespaul

    Thewespaul Supporting Member Supporting Member

    Posts:
    4,151
    Likes Received:
    2,147
    Joined:
    Jul 27, 2015
    Location:
    Bulverde, Texas
    Did you retime it after replacing the injectors?
     
  6. Danish1965

    Danish1965 Registered User

    Posts:
    7
    Likes Received:
    0
    Joined:
    Mar 26, 2018
    Location:
    Oregon
    No. Ignition timing?
     
  7. MICHAEL MICHAUD

    MICHAEL MICHAUD Registered User

    Posts:
    24
    Likes Received:
    8
    Joined:
    Jul 28, 2018
    Location:
    North Carolina
    look up timing the 7.3 idi. for the 94 turbo model you're supposed to time it to 8-9* btdc. You need special equipment to do the timing by generating an electric signal each time the #1 injector line has fuel going through it. tap into that electric signal with an inductive timing light and then check your timing with the engine running at 2000 rpms. there are good videos and posts on how to do it but the equipment is hard to come by unless you know someone with it, find some used or want to spend $300 on a new snap on pulse generator.

    https://www.thedieselstop.com/forums/f30/best-static-timing-7-3-idi-178392/
     
    Thewespaul likes this.
  8. Thewespaul

    Thewespaul Supporting Member Supporting Member

    Posts:
    4,151
    Likes Received:
    2,147
    Joined:
    Jul 27, 2015
    Location:
    Bulverde, Texas
    Pump timing, check out the tech articles for a write up on the procedure, then look for someone near you in the timing registry that has the equipment.
     
  9. Danish1965

    Danish1965 Registered User

    Posts:
    7
    Likes Received:
    0
    Joined:
    Mar 26, 2018
    Location:
    Oregon
    Thank you
     
  10. towcat

    towcat Administrator Staff Member

    Posts:
    18,035
    Likes Received:
    1,215
    Joined:
    Jun 24, 2004
    Location:
    SantaClara,Ca/Hamilton,TX
    rev up the motor. if the white smoke gets worse and it sounds like it's misfiring, it's the pump. it's done.
    if the motor smooths out when you rev it up, it's in the injectors.
     
    Dirtleg likes this.
  11. gandalf

    gandalf Senior Member

    Posts:
    3,111
    Likes Received:
    281
    Joined:
    Jan 21, 2005
    Location:
    CA
    You didn't answer one of the first questions asked. Where did you get the injectors? New or rebuilt? The source matters.
     
    Thewespaul likes this.
  12. IDIBRONCO

    IDIBRONCO IDIBRONCO

    Posts:
    1,724
    Likes Received:
    607
    Joined:
    Feb 5, 2010
    Location:
    edmond, ks
    Another question, does it keep blowing the smoke at higher RPMs or does it quit and act normal again? If it keeps doing this, I'm wondering if it could be sucking some water out of the fuel filter. I don't really know the chances of this being the case, but it's at least a possibility.
     
  13. Danish1965

    Danish1965 Registered User

    Posts:
    7
    Likes Received:
    0
    Joined:
    Mar 26, 2018
    Location:
    Oregon
    Sorry. New injectors from oregon fuel injection in eugene, oregon.
     
  14. Danish1965

    Danish1965 Registered User

    Posts:
    7
    Likes Received:
    0
    Joined:
    Mar 26, 2018
    Location:
    Oregon
    Towcat,
    That is exactly what is happening. Cant get it over 1500 rpm and misfires and will not rev.
     
  15. gandalf

    gandalf Senior Member

    Posts:
    3,111
    Likes Received:
    281
    Joined:
    Jan 21, 2005
    Location:
    CA
    Those should be good injectors. I've nothing but good comments about Oregon Fuel.

    Before you spend any major money be sure to read "The Hall of Shame" It's in the Tech Articles or Stickies somewhere. Not all parts houses supply good products.

    Towcat is very likely right about the IP. Again, Oregon Fuel.
     

Share This Page