7.3 IDI sputtering Only in Low or interstate! Afraid to drive, my only rollback sitting.

Duck

Registered User
Joined
Sep 20, 2022
Posts
2
Reaction score
0
Location
37148
1989 International s1654 Rollback.
First let me tell you what I have done. New lift pump [Old one was leaking underneath] New Fuel Filter, Fuel heater hole plugged because some idiot put JB weld on hoping it would stop leaking. I've bled the whole system, and tried bleeding again to make sure all the air was out.

Now I'll tell you the symptoms.
It's sputters extremely bad in Low and blows white smoke everywhere. The smoke has no smell strong enough to tell what it is. At idle the haze will burn your eyes and throat up, but idles fine. It drives fine in the city as long as I don't have to use Low. If I'm on the interstate or highway I can't cruise at a constant speed. I have to have no throttle or full throttle, if I try holding a consistent speed it starts smoking, sputtering, and almost shutting off.
The truck never gets above 170 degrees, there is no air intrusion, no air in the line I've used a clear line to double check. Fuel pressure before filter was 8psi. I can drive all day shut the truck off, and when I come back from the store 5 minutes later just bump the key and it starts right up. If I drive everyday it starts right up, if it sits a day I have to give it some throttle to get it to start first try, and if it sits two days I can forget about it starting without having to put a jump box on it. Note it is not loosing prime though, and the return line is still on. I checked by removing the filter and fuel was spilling out the moment it became loose. The other day I was below 1/4 tank and it ran perfectly, no stuttering or smoking, and had all it strength back. I went in the store came out and filled it up, the moment I drove off it started sputtering. Also to mention if it idles for long it sputters pretty bad, almost like there is a build up of something. The valley is dry, and no signs of leaking injectors.

It's to the point I'm afraid to drive it, if it breaks down with a customers car on the back there is no way to run my bed.
 

Clb

Another old truck
Supporting Member
Joined
Mar 1, 2013
Posts
5,009
Reaction score
1,453
Location
nannyfornia
Knee jerk reaction....I.p. and inj.
Longshot of the vrv leaking.
8 psi before, but how bout thru the filter?
Try the atf trick w/new filter?
How old are the injection components?
 

Duck

Registered User
Joined
Sep 20, 2022
Posts
2
Reaction score
0
Location
37148
Knee jerk reaction....I.p. and inj.
Longshot of the vrv leaking.
8 psi before, but how bout thru the filter?
Try the atf trick w/new filter?
How old are the injection components?
I did forget to mention I filled the filter with ATF when installed, my apologies.
I am assuming it needs an IP & Injectors, but found it strange I only have issues in one gear then it clears up some days.
I did not check after the filter, nor did I to the filter to check.
VRV is something I did not think to even check, o I'll have to check that.
As far as I know everything is factory at 300k miles, I'm the second owner.
 
Top