2 years of Creeping, finally got another IDI, introduction/build thread from Connecticut.

Discussion in '6.9L IH & 7.3L IDI Diesels' started by Kevo1288, Oct 9, 2018.

  1. Kevo1288

    Kevo1288 Full Access Member

    Age:
    29
    Posts:
    98
    Likes Received:
    39
    Joined:
    Feb 19, 2015
    Location:
    North Grosvenordale
    Do you guys think the pump will be fine as it sits? A little angled?
     
  2. saburai

    saburai Full Access Member

    Posts:
    1,183
    Likes Received:
    421
    Joined:
    Mar 15, 2016
    Location:
    Bokeelia Florida/Catskill mountains NY
    Beautiful truck! I love the color! Welcome...
     
  3. chillman88

    chillman88 Supporting Member Supporting Member

    Posts:
    1,551
    Likes Received:
    808
    Joined:
    Feb 22, 2017
    Location:
    Central NY
    I wouldn't worry about a little angle from a functionality standpoint. My OCD might make me fix it anyway though...
     
  4. Kevo1288

    Kevo1288 Full Access Member

    Age:
    29
    Posts:
    98
    Likes Received:
    39
    Joined:
    Feb 19, 2015
    Location:
    North Grosvenordale

    I'm the same way, so what I did was forced myself to believe that its just following the line of the bracket anyway!cookoo:cheers:
     
    chillman88 likes this.
  5. Kevo1288

    Kevo1288 Full Access Member

    Age:
    29
    Posts:
    98
    Likes Received:
    39
    Joined:
    Feb 19, 2015
    Location:
    North Grosvenordale
    9B6B6700-7E33-4BA5-94C0-CA39A9DE1694.jpeg 580D582A-00BD-4439-9AFA-E369EC40A3FA.jpeg CC2D213C-885D-476D-A595-1754C96D75A2.jpeg 1154CAED-A9AA-4A3F-9BE3-E648BE69607F.jpeg 9EAE1C9F-BA41-4B9E-84EC-11B50FE299CE.jpeg Water pump went much better second time around. Plugs were supplied not already driven in with blue loctite.


    New glow plugs and refurb on the gp harness done.


    Water pump and thermostat done

    New belt done

    Most of the coolant is out


    Just need to plug in the feed line for the facet pump and wire it and she’ll be good to go.


    Figured out my hard start and smoke was due to a loose ip supply line that was leaking fuel. Ordered a new kit from Mike green but that can wait till it gets here.
     
  6. Kevo1288

    Kevo1288 Full Access Member

    Age:
    29
    Posts:
    98
    Likes Received:
    39
    Joined:
    Feb 19, 2015
    Location:
    North Grosvenordale
    86D24635-9BE8-4A5F-B671-97C2088D8E9A.jpeg ED27EBF7-B9B2-47B5-AA30-3E3F79F453CE.jpeg 6718546B-1B99-41AE-AD10-E70B818D6F66.jpeg All done . Water pump, electric fuel pump, glow plugs, tstat, belt , two new batteries
     
    chillman88 and The_Josh_Bear like this.
  7. The_Josh_Bear

    The_Josh_Bear Full Access Member

    Posts:
    198
    Likes Received:
    75
    Joined:
    Jun 1, 2016
    Location:
    Western WA
    Nice work! That always feels good to knock out the maintenance items. Starts and runs well now?
     
  8. Kevo1288

    Kevo1288 Full Access Member

    Age:
    29
    Posts:
    98
    Likes Received:
    39
    Joined:
    Feb 19, 2015
    Location:
    North Grosvenordale

    Glowplug relay started acting funny this morning. So I guess I’ll be buying one of those.

    Last night ran awesome and I ran out of fuel on the test drive, reprimed it today n it seems like I’m getting air in the system again as I’m getting white smoke when giving it throttle as well as a little stumble on idle. Maybe the oring on the ip feed is no good (fitting was loose I tightened it). A push lok feed kid is on its way from mike green though.

    So ya I dno it runs better but still a few mice in the system.
     
  9. The_Josh_Bear

    The_Josh_Bear Full Access Member

    Posts:
    198
    Likes Received:
    75
    Joined:
    Jun 1, 2016
    Location:
    Western WA
    Oh and who is Mike Green? I haven't heard of him before you mentioned in this thread about getting parts from him.
     
  10. D_Fresh361

    D_Fresh361 Supporting Member Supporting Member

    Age:
    27
    Posts:
    231
    Likes Received:
    47
    Joined:
    Jun 28, 2015
    Location:
    Victoria, TX
    Truck looks great! Any info you can provide on that bed topper would be highly grateful! Exactly what I'm looking for! Thanks and Welcome to the forum!
     
  11. D_Fresh361

    D_Fresh361 Supporting Member Supporting Member

    Age:
    27
    Posts:
    231
    Likes Received:
    47
    Joined:
    Jun 28, 2015
    Location:
    Victoria, TX
    How much was the feed line kit if you don't me asking? I need this myself asap
     
  12. Kevo1288

    Kevo1288 Full Access Member

    Age:
    29
    Posts:
    98
    Likes Received:
    39
    Joined:
    Feb 19, 2015
    Location:
    North Grosvenordale

    I don’t know much on the cap but I’ll try and find out. The kit was $55 hrs on the fb idi enthusiast page he sells a steel braided kit for 105 I think, I am a little tight on cash as we just got a house, a puppy, and the truck nickle n dimed me on this project so
    I opted for the push lok kit.
     
    D_Fresh361 likes this.
  13. Kevo1288

    Kevo1288 Full Access Member

    Age:
    29
    Posts:
    98
    Likes Received:
    39
    Joined:
    Feb 19, 2015
    Location:
    North Grosvenordale

    I dno if this is against the rules but here’s the page he has on fb. He also has tons of misc factory parts.

    47F9A40F-E11F-446B-A3EC-AFFFB43F63FD.png
     
    D_Fresh361 likes this.
  14. HS108

    HS108 Diesel Newb

    Posts:
    733
    Likes Received:
    55
    Joined:
    Mar 5, 2013
    Location:
    Connecticut
    Whats the GP Relay doing?
     
  15. Kevo1288

    Kevo1288 Full Access Member

    Age:
    29
    Posts:
    98
    Likes Received:
    39
    Joined:
    Feb 19, 2015
    Location:
    North Grosvenordale

    The relay clicks , the wait to start light turns on with key on and immediately turns off. Occasionally when the truck is "warm" the wts light stays on for 2 Mississippi's and then shuts off.

    I should have said "controller" not relay as I think the relay is working properly.
     

Share This Page