1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

1996 f-450 overheat 460 engine

Discussion in 'Gasoline Engines' started by trythis, Jan 28, 2019.

  1. trythis

    trythis Full Access Member

    Posts:
    55
    Likes Received:
    1
    Joined:
    Oct 5, 2010
    Location:
    Commiskey IN
    Having trouble with this thing overheating change the water pump change the radiator all looks good .
    I also scoped the cylinder walls could see carbon on the top of each cylinder all cylinders look the same all cylinders have 120 PSI compression test
    I've got no idea where to go from here.
    Do not see any bubbles coming up the radiator
    Truck only gets hot when you work it hard.
    Tell me what else you need to know thank you IMG_20190119_211555.jpg
     
  2. Thewespaul

    Thewespaul Supporting Vendor Supporting Member

    Posts:
    7,752
    Likes Received:
    5,940
    Joined:
    Jul 27, 2015
    Location:
    Bulverde, Texas
    Have you checked to see if the thermostat is partially blocked? Checked timing?
     
  3. trythis

    trythis Full Access Member

    Posts:
    55
    Likes Received:
    1
    Joined:
    Oct 5, 2010
    Location:
    Commiskey IN
    yes I have checked both 10*with spout out and no thermostat. thank you
     
  4. stealth13777

    stealth13777 Full Access Member

    Posts:
    482
    Likes Received:
    25
    Joined:
    May 28, 2014
    Location:
    Jacksonville, FL
    Not familiar with the truck, but mechanical fan? Could it be that the fan isn’t as good as it once was?
     
  5. chris142

    chris142 Full Access Member

    Posts:
    2,695
    Likes Received:
    202
    Joined:
    Apr 15, 2012
    Location:
    SoCal
    Is the plate on the rear of the water pump missing?
     
  6. trythis

    trythis Full Access Member

    Posts:
    55
    Likes Received:
    1
    Joined:
    Oct 5, 2010
    Location:
    Commiskey IN
    I missed this last time I was working on this the answer to your question is I don't know I did change the water pump but I don't remember a plate covering the fens I wonder if anybody has a picture

    Sent from my moto g(7) optimo maxx(XT1955DL) using Tapatalk
     
  7. 79jasper

    79jasper Chickenhawk

    Age:
    27
    Posts:
    16,511
    Likes Received:
    1,484
    Joined:
    Oct 13, 2012
    Location:
    Collinsville, Oklahoma
    Quick Google search. [​IMG]

    Sent from my SM-N960U using Tapatalk
     
  8. Ironman03R

    Ironman03R Full Access Member

    Age:
    36
    Posts:
    2,150
    Likes Received:
    104
    Joined:
    Jan 8, 2006
    Location:
    Risingsun, OH (NW OH)
    No thermostat? As in it is removed?
     
  9. trythis

    trythis Full Access Member

    Posts:
    55
    Likes Received:
    1
    Joined:
    Oct 5, 2010
    Location:
    Commiskey IN
    I did have it removed but I put one back in I don't think it's the thermostat because it takes it too long to get hot I have to drive quite a ways 60 miles in hot weather. But I have to say I just don't know

    Sent from my moto g(7) optimo maxx(XT1955DL) using Tapatalk
     
  10. trythis

    trythis Full Access Member

    Posts:
    55
    Likes Received:
    1
    Joined:
    Oct 5, 2010
    Location:
    Commiskey IN
    Not sure how thick the plate would be check this picture out there is a gasket but I don't think there's a plate.[​IMG]

    Sent from my moto g(7) optimo maxx(XT1955DL) using Tapatalk
     

Share This Page