1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

1986 6.9 fuel issues

Discussion in '6.9L IH & 7.3L IDI Diesels' started by Laine D, Nov 3, 2019.

  1. Laine D

    Laine D Full Access Member

    Posts:
    72
    Likes Received:
    21
    Joined:
    Jan 23, 2019
    Location:
    Northern California
    So here’s my issue. I run my front tank out of fuel on accident. Then I switch to the rear tank and it’s fine for a day or 2. Then today I went out to start it and I had to crank on it for a while, and a couple times during the day it would idle like its running Out of fuel.. I have a Duralift electric pump and I look at the clear bowl and it looks wayyy lower than usual. I don’t have a fuel psi gauge but I’m assuming it’s low. Check return lines and there are no leaks or anything. Hit the shrader valve on the filter and it blows a bunch of air out. That was Kinda weird. THEN, I find the fuel line between the metal and plastics return lines that is over the bell housing leading back to the tanks is leaking a little. Makes sense with the air intrusion. But when I go to fill up my front tank it only takes 3.38 gallons. Anybody else ever had this happen? Everything else on the truck is new except for the tank selector and the tank pickups... might be dropping the tanks soon. Was really weird because it was intermittent
     
  2. Laine D

    Laine D Full Access Member

    Posts:
    72
    Likes Received:
    21
    Joined:
    Jan 23, 2019
    Location:
    Northern California
    Also. It only started running weird once I had it on the back tank. It ran fine on the front until it ran out. The fuel gauge also is always at empty now on the rear tank and it has always worked normal so I’m not sure what that means.
     
  3. IDIBRONCO

    IDIBRONCO IDIBRONCO

    Posts:
    4,291
    Likes Received:
    2,584
    Joined:
    Feb 5, 2010
    Location:
    edmond, ks
    I'm betting that your issue is in the tank selector valve. It sounds to me like it's sticking between both tanks. Like it's returning the fuel to the front tank instead of the rear. This will drain the rear tank while filling the front. The fuel gauge suddenly not working on the rear tank also makes me lean toward the selector valve. I'd bet that your rear tank is getting low on fuel after the first couple of days when it was fine. You don't know this since the gauge isn't working.
     
  4. Laine D

    Laine D Full Access Member

    Posts:
    72
    Likes Received:
    21
    Joined:
    Jan 23, 2019
    Location:
    Northern California
    I was thinking the same thing but then I clicked the switch a few times and heard it switch clearly. I haven’t put and fuel in the rear tank yet though. I will grab some tonight. Is it a possibility the selector was just stuck that one time?
     
  5. IDIBRONCO

    IDIBRONCO IDIBRONCO

    Posts:
    4,291
    Likes Received:
    2,584
    Joined:
    Feb 5, 2010
    Location:
    edmond, ks
    It's possible. When you switch it, try to move the switch up and down slightly. I had a 1979 F150 that you had to do this to before the fuel gauge would work after switching tanks.
     
  6. Laine D

    Laine D Full Access Member

    Posts:
    72
    Likes Received:
    21
    Joined:
    Jan 23, 2019
    Location:
    Northern California
    Al
    sicK I’ll try that. Funny now I can remember my dad fixing the selector on his 86’ back when I was like 10. In pretty sure his was doing the exact same thing
     
  7. IDIBRONCO

    IDIBRONCO IDIBRONCO

    Posts:
    4,291
    Likes Received:
    2,584
    Joined:
    Feb 5, 2010
    Location:
    edmond, ks
    If it gets your gauges working again and it's working right, then you can decide whether or not to replace the valve.
     
  8. Laine D

    Laine D Full Access Member

    Posts:
    72
    Likes Received:
    21
    Joined:
    Jan 23, 2019
    Location:
    Northern California
    Thanks you. I’m almost certain it is the valve. Ill see what’s up after I fill it up again
     
  9. Laine D

    Laine D Full Access Member

    Posts:
    72
    Likes Received:
    21
    Joined:
    Jan 23, 2019
    Location:
    Northern California
    So I finally was able to fill up both the tanks. Air in the system again and the front tank keeps filling back up. I don’t know what else it could be other than that selector valve.
     
    Cainon likes this.
  10. IDIBRONCO

    IDIBRONCO IDIBRONCO

    Posts:
    4,291
    Likes Received:
    2,584
    Joined:
    Feb 5, 2010
    Location:
    edmond, ks
    The only thing that controls the fuel draw and return is the selector valve. I'd say that's your problem.
     
    RetiringColt and Trevtron like this.
  11. Laine D

    Laine D Full Access Member

    Posts:
    72
    Likes Received:
    21
    Joined:
    Jan 23, 2019
    Location:
    Northern California
    Would I be able to take it apart and clean it up inside and see if something is wrong inside?
     
  12. IDIBRONCO

    IDIBRONCO IDIBRONCO

    Posts:
    4,291
    Likes Received:
    2,584
    Joined:
    Feb 5, 2010
    Location:
    edmond, ks
    I know some have done this successfully. They are held together buyrivets. You have to drill out the rivets and then install screws to put it back together. I have not attempted this so I don't really have any farther information about this.
     
  13. Laine D

    Laine D Full Access Member

    Posts:
    72
    Likes Received:
    21
    Joined:
    Jan 23, 2019
    Location:
    Northern California
    I’d like to try to get it apart soon. Just can’t have my truck down for that long because of work and stuff. Hoping it’ll take me a solid afternoon
     
  14. Laine D

    Laine D Full Access Member

    Posts:
    72
    Likes Received:
    21
    Joined:
    Jan 23, 2019
    Location:
    Northern California
    6BFD850C-E254-4518-8F3F-A04F7F79C1C5.png I just found this. It’s the blade terminal also, it’s for 75$. I’m unsure what brand. It says it was 300$ but it’s discounted or something.
     
    RetiringColt likes this.
  15. RetiringColt

    RetiringColt Supporting Member Supporting Member

    Posts:
    44
    Likes Received:
    21
    Joined:
    Mar 18, 2019
    Location:
    Washougal WA.
    I'm running an eBay selector valve in my rig. it came with a new blade type connector. it was a direct fit for $68 plus tax and shipping. my old connector was broken. I just un-pinned the connector and installed the old pins into new connector. I tried to open the old selector and did get it opened, but the plastic was brittle and kept breaking. it was really dirty inside. almost like the plastic was etched/eroded. I changed the O-rings in the fuel unions while I had it out too. that was definitely a tricky little operation. I checked operation by disconnecting the fuel unions of the opposite tank while the engine was running. The front lines off while using from the back and vise versa. Everything is working as it should now.
     

Share This Page