05 No FICM Logic or Main power

Discussion in '6.0L Powerstroke Diesels' started by Ford428CJ, Feb 19, 2018.

  1. Ford428CJ

    Ford428CJ FE Freak!

    Posts:
    195
    Likes Received:
    3
    Joined:
    Nov 17, 2007
    Location:
    Klamath Falls, Oregon
    Ok here it goes. I changed out a HPOP in this thing. Put it all back together. Now I lost Main and Logic power to the FICM. I checked the Fuses. Those seam to be fine.

    I went to the FICM relay. Pin 1 and 5 have power (12.6v) all the time. Pin 2 I assume is a switched ground to trigger the relay!? I have nothing on Pin 2. The relay works as advertised and checked it. Any help would be appreciated ! Thanks
     
  2. Ford428CJ

    Ford428CJ FE Freak!

    Posts:
    195
    Likes Received:
    3
    Joined:
    Nov 17, 2007
    Location:
    Klamath Falls, Oregon
    [​IMG]


    Sent from my iPhone using Tapatalk
     
  3. 79jasper

    79jasper Chickenhawk

    Age:
    25
    Posts:
    15,345
    Likes Received:
    916
    Joined:
    Oct 13, 2012
    Location:
    Collinsville, Oklahoma
    I've seen this problem pop up in the forums. Can't currently remember the common offender.

    Sent from my SM-G892A using Tapatalk
     
    Ford428CJ likes this.
  4. Dsl_Dog_Treat

    Dsl_Dog_Treat I lost my face to the jaws of a poodle Staff Member

    Age:
    47
    Posts:
    7,148
    Likes Received:
    72
    Joined:
    Jan 13, 2005
    Location:
    Decatur,MI
    Harness connectors seated properly?
    Harness ground wire connected?
    Iirc pins 1,2,3,22&26 are all internal grounds and shouldn't pop a code.
     
    bismic1 likes this.
  5. Ford428CJ

    Ford428CJ FE Freak!

    Posts:
    195
    Likes Received:
    3
    Joined:
    Nov 17, 2007
    Location:
    Klamath Falls, Oregon
    Yes Sir. The harness is seated properly and I pulled it again to make sure no bent pins. And reseated again. The harness ground wire is connected in the back told the intake manifold.


    Sent from my iPhone using Tapatalk
     
  6. Ford428CJ

    Ford428CJ FE Freak!

    Posts:
    195
    Likes Received:
    3
    Joined:
    Nov 17, 2007
    Location:
    Klamath Falls, Oregon
    No codes popped


    Sent from my iPhone using Tapatalk
     
  7. Ford428CJ

    Ford428CJ FE Freak!

    Posts:
    195
    Likes Received:
    3
    Joined:
    Nov 17, 2007
    Location:
    Klamath Falls, Oregon
    [​IMG]

    [​IMG]

    So I assume Pin 2 on the FICM relay goes to that?


    Sent from my iPhone using Tapatalk
     
  8. Dsl_Dog_Treat

    Dsl_Dog_Treat I lost my face to the jaws of a poodle Staff Member

    Age:
    47
    Posts:
    7,148
    Likes Received:
    72
    Joined:
    Jan 13, 2005
    Location:
    Decatur,MI
    Here's the pinout for the ficm if you don't have it yet.
    I'd say for shitzngiggles to unplug the fan clutch harness but no code popped for a fault.
    Beginning to think your harness may be at fault since you have power in and out of the relay.

    2009-03-30_235400_2.gif
     
    bismic1 likes this.
  9. Ford428CJ

    Ford428CJ FE Freak!

    Posts:
    195
    Likes Received:
    3
    Joined:
    Nov 17, 2007
    Location:
    Klamath Falls, Oregon

    I have the power at the relay. I used my snap on test light and checked all the grounds at the plug to the FICM. They are dead!

    Thanks for the Diagram


    Sent from my iPhone using Tapatalk
     
  10. Ford428CJ

    Ford428CJ FE Freak!

    Posts:
    195
    Likes Received:
    3
    Joined:
    Nov 17, 2007
    Location:
    Klamath Falls, Oregon
    I even swapped FICM with a well known one that works. Nothing! Dead as a nail!


    Sent from my iPhone using Tapatalk
     
  11. Ford428CJ

    Ford428CJ FE Freak!

    Posts:
    195
    Likes Received:
    3
    Joined:
    Nov 17, 2007
    Location:
    Klamath Falls, Oregon
    I even unplugged the fan clutch


    Sent from my iPhone using Tapatalk
     
  12. Ford428CJ

    Ford428CJ FE Freak!

    Posts:
    195
    Likes Received:
    3
    Joined:
    Nov 17, 2007
    Location:
    Klamath Falls, Oregon
    Well... Got a game plan..... The back grounding wire ties all those grounds together. I assume the junction of where they all meet would be at the base of the 3X plug. I’ll have to trace it and see where the break is at.


    Sent from my iPhone using Tapatalk Pro
     
  13. Ford428CJ

    Ford428CJ FE Freak!

    Posts:
    195
    Likes Received:
    3
    Joined:
    Nov 17, 2007
    Location:
    Klamath Falls, Oregon
    [​IMG]

    [​IMG]

    [​IMG]

    Found the problems and fixed them! She runs


    Sent from my iPhone using Tapatalk
     
  14. Dsl_Dog_Treat

    Dsl_Dog_Treat I lost my face to the jaws of a poodle Staff Member

    Age:
    47
    Posts:
    7,148
    Likes Received:
    72
    Joined:
    Jan 13, 2005
    Location:
    Decatur,MI
    Good find!
     
    Ford428CJ likes this.
  15. Ford428CJ

    Ford428CJ FE Freak!

    Posts:
    195
    Likes Received:
    3
    Joined:
    Nov 17, 2007
    Location:
    Klamath Falls, Oregon
    Someone was tough on this ole 6.0. Lucky I have a over head creeper. And happen to look under the anti lock Break motor.... And noticed the cannon plug wasn’t seated....


    Sent from my iPhone using Tapatalk Pro
     

Share This Page