Correct timing procedure for 89 7.3 injector pump

Discussion in '6.9L IH & 7.3L IDI Diesels' started by ny.wolcott, Oct 23, 2009.

  1. ny.wolcott

    ny.wolcott Registered User

    Posts:
    4
    Likes Received:
    0
    Joined:
    Oct 23, 2009
    Location:
    worcester, ny
    I have an '89 Ford 7.3 diesel. I suspect the mechanic incorrectly timed the injector pump after removing and replacing it to correct and oil leak, as it's smoking black heavily and running weakly.

    What is the correct procedure to align the pump gear with the engine gear?

    Thanks.
     
  2. Agnem

    Agnem Using the Force! Staff Member Supporting Member

    Age:
    53
    Posts:
    16,938
    Likes Received:
    5
    Joined:
    Jan 10, 2005
    Location:
    Delta, PA
    Welcome to the site. Sorry to see your first post is another one of the "my mechanic was incompetent" variety. You need Ziggsters write up.
     
  3. hesutton

    hesutton The Anti-Anderson

    Age:
    41
    Posts:
    7,590
    Likes Received:
    0
    Joined:
    Aug 19, 2005
    Location:
    Bowling Green, KY
    Wow. That's not good. There are timing marks on the IP gear and on the cam gear. The mark for the IP is a "Y" and you should make sure they are aligned if you think the gear has been installed out of time. There is also a "o" stamped on the cam gear and is it for the crank gear, not the IP gear. Just to summerize "Y" to "Y" for the IP to cam gear timing and "o" to "o" for cam to crank timing.

    Read Zigg's article to more info.

    Heath
     
    Last edited: Oct 23, 2009
  4. ny.wolcott

    ny.wolcott Registered User

    Posts:
    4
    Likes Received:
    0
    Joined:
    Oct 23, 2009
    Location:
    worcester, ny
    Thank you so much!

    Now I can talk intelligently with my mechanic and find out just what he did.
     

Share This Page