Hi, Everbody; Just joined Oilburners as this seems to be the place go for IDI information. Anyway, I am hoping somebody can help me out with my problem. I have 1994 F350 4x4 crew cab with one of the last 7.3 idi's Ford put in before the Powerstroke. It is a retired Air Force truck that I bought a couple of years ago with 32,000 original miles on it. It now has 58, 000 miles on it and has been a great truck, up until now. It will start fine cold, and runs great cold or warmed up. But, it doesn't want to start when it has been warmed up, then shut down for 10-15 minutes or more, so that the IP heat soaks a bit. If I try to restart within 5 minutes of shut down, it will start. Wait 10 minutes or more though, and it doesn't want to start until it cools a bit. Reading up on this problem, most say the IP is in need of a rebuild due to heat expansion of the worn parts so it can;t pop the injectors. I didn't think this was the case as the truck runs great and has low miles. I always run Opti-Lube for fuel lubricty too. I started to investigate the FSS, and think that may be my problem. The last time the truck wouldn't start after warming up and then sitting, I disconnected the FSS wire. I then turned on the ignition, and touched the FSS wire to the FSS terminal. After I did this a couple of times, I could hear the solenoid really click. I hooked the wire back up, hit the key and she fired right up! Since I think this is the problem, I ordered the FSS replacement kit from The Diesel Store. My problem though is I need replacment instructions. I have heard that you can have a run-away engine if the FSS is not installed exactly correct. Has anyone done this replacement? Is there a write up in the forums somewhere that somebody can direct me too? Any special tools needed or pitfalls to watch out for? I appreciate any advice or suggestions you may have. I am hoping to get another 40,000 miles out of the IP before rebuild. Thanks! Todd